Unoffical empeg BBS

Quick Links: Empeg FAQ | Software | RioCar.Org | Hijack | jEmplode | emphatic
Repairs: Repairs | Addons: Eutronix | Cases

Page 1 of 2 1 2 >
Topic Options
#138405 - 31/01/2003 00:56 HELP half dead RIO
Turboegt
new poster

Registered: 30/07/2002
Posts: 24
Loc: Fl, USA
Hello. I have got a small, I hope, problem with my Rio player. It has just been sitting here for a while, never in my car yet, on my desk. I have been going through scanning and fixing all my MP3 to get rid of the errors some of then get on the Rio player so I have not been using it much lately. Tonight some friends can over and so I wanted to show then just how cool the Rio is. It was working fine, display was going though all the cool stuff and was playing just fine. I then wanted to really blow there minds so I jumped on Exploder to show then how cool the web interface was. It was working good but then it started to not work so well and finally stopped altogether. I reset the player, hub and computer and that seened to fix it for a few minute but then it looked the Rio up, well some of it anyways. OK, now all I get is the RIO screen and if I hold down the knob I can get the other stuff that is on there ( I have all the latest kernels and Emplode). The player will work if you restart it but only within the first few seconds. After that the only controls that work is holding down the knob to get into those option and then screen freezes. Strangely the player will still play and keep playing even after the controls stop working. After some investigation I did realize the screen will go into sleep mode and will come back to life with the touch of any buttom. I have tried to resinc the player using both the Com and Net. You can get it to sinc if you play with it long enough but it still does the same thing. Am I just totally overlooking something stupid here or what. Please help me fix my beloved Rio Player.

P.S.- sorry for the long post but I wanted to make sure I explained everything that is going on and what I have already tried.

Thanks in advance for you help

Top
#138406 - 31/01/2003 01:46 Re: HELP half dead RIO [Re: Turboegt]
loren
carpal tunnel

Registered: 23/08/2000
Posts: 3824
Loc: SLC, UT, USA
first, read this faq entry:

http://www.riocar.org/modules.php?op=modload&name=FAQ&file=index&myfaq=yes&id_cat=7&faqent=82#82

then once you're hooked up to the terminal, post the boot up log here.

I can't think of anything off hand that would do that, so if there are any errors in the bootup it might help. Anyone else recognize these symptoms? Ram maybe?
_________________________
|| loren ||

Top
#138407 - 31/01/2003 02:07 Re: HELP half dead RIO [Re: Turboegt]
matthew_k
pooh-bah

Registered: 12/02/2002
Posts: 2296
Loc: Berkeley, California
The only thing that sounds vaugely familiar was someone who was having problems with their empeg just getting bogged down from some virus on the network (nimda?). Perhaps try it without the ethernet cable plugged in? I doubt that's it from your description though.

It also sounds like stuck jiffies, but those were fixed a while ago and were never regular for anyone.

Try reflashing a stock empeg image and see if that does anything perhaps?

Matthew

Top
#138408 - 31/01/2003 02:23 Re: HELP half dead RIO [Re: loren]
Turboegt
new poster

Registered: 30/07/2002
Posts: 24
Loc: Fl, USA

empeg-car bootstrap v1.02 20001106 (hugo@empeg.com)
If there is anyone present who wants to upgrade the flash, let them speak now,
or forever hold their peace...it seems not. Let fly the Penguins of Linux!

e000 v1.04
Copying kernel...
Calling linux kernel...
Uncompressing Linux................................... done, booting the kernel.

Linux version 2.2.14-rmk5-np17-empeg51-hijack-v291 (root@tbird.localnet) (gcc ve
rsion 2.95.3 20010315 (release)) #2 Wed Jul 31 10:10:42 EDT 2002
Processor: Intel StrongARM-1100 revision 11
NetWinder Floating Point Emulator V0.94.1 (c) 1998 Corel Computer Corp.
empeg-car player (hardware revision 9, serial number 30102349)
Command line: mem=16m
Calibrating delay loop... 207.67 BogoMIPS
Memory: 15076k/16M available (928k code, 20k reserved, 356k data, 4k init)
Dentry hash table entries: 2048 (order 2, 16k)
Buffer cache hash table entries: 16384 (order 4, 64k)
Page cache hash table entries: 4096 (order 2, 16k)
POSIX conformance testing by UNIFIX
Linux NET4.0 for Linux 2.2
Based upon Swansea University Computer Society NET3.039
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP
TCP: Hash tables configured (ehash 16384 bhash 16384)
IrDA (tm) Protocols for Linux-2.2 (Dag Brattli)
Linux-IrDA: IrCOMM protocol ( revision:Tue May 18 03:11:39 1999 )
ircomm_tty: virtual tty driver for IrCOMM ( revision:Wed May 26 00:49:11 1999 )
Starting kswapd v 1.5
SA1100 serial driver version 4.27 with no serial options enabled
ttyS00 at 0xf8010000 (irq = 15) is a SA1100 UART
ttyS01 at 0xf8050000 (irq = 17) is a SA1100 UART
ttyS02 at 0xf8030000 (irq = 16) is a SA1100 UART
Signature is 636f6972 'rioc'
Found custom animation at offset 0x9f750
Scheduling custom logo.
empeg display initialised.
empeg dsp audio initialised
empeg dsp mixer initialised
empeg dsp initialised
empeg audio-in initialised, CS4231A revision a0
empeg remote control/panel button initialised.
empeg usb initialised, PDIUSBD12 id 1012
empeg state support initialised 0089/88c1 (save to d0005080).
empeg RDS driver initialised
empeg power-pic driver initialised (first boot)
RAM disk driver initialized: 16 RAM disks of 4096K size
empeg single channel IDE
Probing primary interface...
hda: IBM-DJSA-220, ATA DISK drive
ide0 at 0x000-0x007,0x038 on irq 6
hda: IBM-DJSA-220, 19077MB w/1874kB Cache, CHS=38760/16/63
empeg-flash driver initialized
smc chip id/revision 0x3349
smc9194.c:v0.12 03/06/96 by Erik Stahlman (erik@vt.edu)

SMC9194: SMC91C94(r:9) at 0x4008000 IRQ:7 INTF:TP MEM:6144b MAC 00:02:d7:26:09:2
d
Partition check:
hda: hda1 < hda5 hda6 > hda2 hda3 hda4
RAMDISK: ext2 filesystem found at block 0
RAMDISK: Loading 320 blocks [1 disk] into ram disk... done.
VFS: Mounted root (ext2 filesystem).
empeg-pump v0.03 (19980601)
Press Ctrl-A to enter pump...VFS: Mounted root (ext2 filesystem) readonly.
change_root: old root has d_count=1
Trying to unmount old root ... okay
Freeing unused kernel memory: 4k init
khttpd: listening on port 80
kftpd: listening on port 21
player.cpp : 385:empeg-car 2.00-beta13 2002/07/24.
Prolux 4 empeg car - 2.1434 Jul 24 2002
Vcb: 0x4086d000
serial_notify_thread.cpp: 116:@@ N13
serial_notify_thread.cpp: 117:@@ F0x720
serial_notify_thread.cpp: 118:@@ TJellyhead
serial_notify_thread.cpp: 119:@@ ACrush
serial_notify_thread.cpp: 120:@@ G
serial_notify_thread.cpp: 116:@@ N13
serial_notify_thread.cpp: 117:@@ F0x720
serial_notify_thread.cpp: 118:@@ TJellyhead
serial_notify_thread.cpp: 119:@@ ACrush
serial_notify_thread.cpp: 120:@@ G
serial_notify_thread.cpp: 180:@@ #720 0:00:48
serial_notify_thread.cpp: 170:@@ S1
! mp3_decoder.cpp :1049:Failed to find valid sync after seeking to offset 7659
52, error=0xc0044000
serial_notify_thread.cpp: 180:@@ #720 0:00:49
serial_notify_thread.cpp: 180:@@ #720 0:00:50
serial_notify_thread.cpp: 180:@@ #720 0:00:51
serial_notify_thread.cpp: 180:@@ #720 0:00:52
serial_notify_thread.cpp: 180:@@ #720 0:00:53
serial_notify_thread.cpp: 180:@@ #720 0:00:54
serial_notify_thread.cpp: 180:@@ #720 0:00:55
serial_notify_thread.cpp: 180:@@ #720 0:00:56
serial_notify_thread.cpp: 180:@@ #720 0:00:57
serial_notify_thread.cpp: 180:@@ #720 0:00:58
serial_notify_thread.cpp: 180:@@ #720 0:00:59
serial_notify_thread.cpp: 180:@@ #720 0:01:00
serial_notify_thread.cpp: 180:@@ #720 0:01:01
serial_notify_thread.cpp: 180:@@ #720 0:01:02
serial_notify_thread.cpp: 180:@@ #720 0:01:03


I sure hope this mean something to you, LOL.

Top
#138409 - 31/01/2003 02:33 Re: HELP half dead RIO [Re: loren]
Turboegt
new poster

Registered: 30/07/2002
Posts: 24
Loc: Fl, USA
Did a ram test too:

empeg-car bootstrap v1.02 20001106 (hugo@empeg.com)
If there is anyone present who wants to upgrade the flash, let them speak now,
or forever hold their peace...
0000 empeg-car (issue9) board test version 0.05 <hugo@empeg.com>
0100 ram test starting
0110 testing ic 1 (0-15mb, low word)
0120 testing ic 2 (0-15mb, high word)
01f0 ram test done
0200 ide detect
0210 command issued
0220 drive id IBM-DJSA-220
02f0 ide ok
0300 dsp/i2c test
03f0 dsp/i2c ok
0400 temperature detect
0410 temperature is 39
04f0 temperature ok
0500 usb detect
0510 usb rev 1012
05f0 usb ok
0600 ethernet detect
0610 ethernet rev 334b
06f0 ethernet ok
0700 cs4231 detect
0710 cs4231 rev a0
07f0 cs4231 ok
00f0 tests complete

I think the RAM looks OK

Top
#138410 - 31/01/2003 04:40 Re: HELP half dead RIO [Re: Turboegt]
pgrzelak
carpal tunnel

Registered: 15/08/2000
Posts: 4859
Loc: New Jersey, USA
Greetings!

Okay. Hijack 291, so it shouldn't be jiffies. There were some notify fixes after that, so upgrading hijack might help. Also, I notice you have a custom boot logo. That shouldn't matter, but if it is too long, it might be causing trouble.

What interests me is that the file lost sync. It seems like you might have a bad mp3 file, and the player is trying to recover. I would not have thought that would lock up the controls, though.

How long has it been since a full sync and disk check on this player? Perhaps you should look for file system issues with a good fsck.
_________________________
Paul Grzelak
200GB with 48MB RAM, Illuminated Buttons and Digital Outputs

Top
#138411 - 31/01/2003 04:50 Re: HELP half dead RIO [Re: pgrzelak]
peter
carpal tunnel

Registered: 13/07/2000
Posts: 4146
Loc: Cambridge, England
What interests me is that the file lost sync. It seems like you might have a bad mp3 file, and the player is trying to recover. I would not have thought that would lock up the controls, though.

The file didn't lose sync; that's the normal message everyone gets before playback starts if it restarts in the middle of a track. Notice there are no timecodes before the sync message, only information that the player knows about before it starts playing.

Unfortunately I've no idea what the real problem is. It's a good start to see whether it still happens with a completely stock 2.0beta13 install.

Peter

Top
#138412 - 31/01/2003 07:04 Re: HELP half dead RIO [Re: peter]
Turboegt
new poster

Registered: 30/07/2002
Posts: 24
Loc: Fl, USA
OK, I upgraded to v301 and it is still was same. I cleared any and all boot logos and antimation and that did not help. I then went back to the stock 2.0beta13 and it is still the same. Here is what I get:


empeg-car bootstrap v1.02 20001106 (hugo@empeg.com)
If there is anyone present who wants to upgrade the flash, let them speak now,
or forever hold their peace...it seems not. Let fly the Penguins of Linux!

e000 v1.04
Copying kernel...
Calling linux kernel...
Uncompressing Linux..................................... done, booting the kerne
l.
Linux version 2.2.14-rmk5-np17-empeg51 (mac@aphex) (gcc version 2.95.3 20010315
(release)) #17 Wed Jul 24 18:23:20 BST 2002
Processor: Intel StrongARM-1100 revision 11
NetWinder Floating Point Emulator V0.94.1 (c) 1998 Corel Computer Corp.
empeg-car player (hardware revision 9, serial number 30102349)
Command line: mem=16m
Calibrating delay loop... 207.67 BogoMIPS
Memory: 15024k/16M available (964k code, 20k reserved, 372k data, 4k init)
Dentry hash table entries: 2048 (order 2, 16k)
Buffer cache hash table entries: 16384 (order 4, 64k)
Page cache hash table entries: 4096 (order 2, 16k)
POSIX conformance testing by UNIFIX
Linux NET4.0 for Linux 2.2
Based upon Swansea University Computer Society NET3.039
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP
TCP: Hash tables configured (ehash 16384 bhash 16384)
IrDA (tm) Protocols for Linux-2.2 (Dag Brattli)
Linux-IrDA: IrCOMM protocol ( revision:Tue May 18 03:11:39 1999 )
ircomm_tty: virtual tty driver for IrCOMM ( revision:Wed May 26 00:49:11 1999 )
Starting kswapd v 1.5
SA1100 serial driver version 4.27 with no serial options enabled
ttyS00 at 0xf8010000 (irq = 15) is a SA1100 UART
ttyS01 at 0xf8050000 (irq = 17) is a SA1100 UART
ttyS02 at 0xf8030000 (irq = 16) is a SA1100 UART
Signature is 206f6972 'rio '
empeg display initialised.
empeg dsp audio initialised
empeg dsp mixer initialised
empeg dsp initialised
empeg audio-in initialised, CS4231A revision a0
empeg remote control/panel button initialised.
empeg usb initialised, PDIUSBD12 id 1012
empeg state support initialised 0089/88c1 (save to d0005b80).
empeg RDS driver initialised
empeg power-pic driver initialised (first boot)
RAM disk driver initialized: 16 RAM disks of 4096K size
empeg single channel IDE
Probing primary interface...
hda: IBM-DJSA-220, ATA DISK drive
hda: IBM-DJSA-220, ATA DISK drive
hda: IBM-DJSA-220, ATA DISK drive
hda: IBM-DJSA-220, ATA DISK drive
hda: IBM-DJSA-220, ATA DISK drive
hda: IBM-DJSA-220, ATA DISK drive
ide0 at 0x000-0x007,0x038 on irq 6
hda: IBM-DJSA-220, 19077MB w/1874kB Cache, CHS=38760/16/63
empeg-flash driver initialized
smc chip id/revision 0x3349
smc9194.c:v0.12 03/06/96 by Erik Stahlman (erik@vt.edu)

SMC9194: SMC91C94(r:9) at 0x4008000 IRQ:7 INTF:TP MEM:6144b MAC 00:02:d7:26:09:2
d
Partition check:
hda: hda1 < hda5 hda6 > hda2 hda3 hda4
RAMDISK: ext2 filesystem found at block 0
RAMDISK: Loading 320 blocks [1 disk] into ram disk... done.
VFS: Mounted root (ext2 filesystem).
empeg-pump v0.03 (19980601)
Press Ctrl-A to enter pump...VFS: Mounted root (ext2 filesystem) readonly.
change_root: old root has d_count=1
Trying to unmount old root ... okay
Freeing unused kernel memory: 4k init player.cpp : 385:empeg-car 2.00-be
ta13 2002/07/24.
Prolux 4 empeg car - 2.1434 Jul 24 2002
Vcb: 0x4086d000
serial_notify_thread.cpp: 116:@@ N53
serial_notify_thread.cpp: 117:@@ F0xa80
serial_notify_thread.cpp: 118:@@ TDoo Doo Brown
serial_notify_thread.cpp: 119:@@ ALuke
serial_notify_thread.cpp: 120:@@ GOther
serial_notify_thread.cpp: 116:@@ N53
serial_notify_thread.cpp: 117:@@ F0xa80
serial_notify_thread.cpp: 118:@@ TDoo Doo Brown
serial_notify_thread.cpp: 119:@@ ALuke
serial_notify_thread.cpp: 120:@@ GOther
serial_notify_thread.cpp: 180:@@ #a80 0:02:02
serial_notify_thread.cpp: 170:@@ S1
! mp3_decoder.cpp :1049:Failed to find valid sync after seeking to offset 1947
200, error=0xc0044000
serial_notify_thread.cpp: 180:@@ #a80 0:02:03
serial_notify_thread.cpp: 180:@@ #a80 0:02:04
serial_notify_thread.cpp: 180:@@ #a80 0:02:06
serial_notify_thread.cpp: 180:@@ #a80 0:02:07
serial_notify_thread.cpp: 180:@@ #a80 0:02:08
serial_notify_thread.cpp: 180:@@ #a80 0:02:09
serial_notify_thread.cpp: 180:@@ #a80 0:02:10
serial_notify_thread.cpp: 180:@@ #a80 0:02:11
serial_notify_thread.cpp: 180:@@ #a80 0:02:12
serial_notify_thread.cpp: 180:@@ #a80 0:02:13
serial_notify_thread.cpp: 180:@@ #a80 0:02:14
serial_notify_thread.cpp: 180:@@ #a80 0:02:15
serial_notify_thread.cpp: 180:@@ #a80 0:02:16

then it stops responding.


Edited by Turboegt (31/01/2003 07:07)

Top
#138413 - 31/01/2003 07:30 Re: HELP half dead RIO [Re: Turboegt]
pgrzelak
carpal tunnel

Registered: 15/08/2000
Posts: 4859
Loc: New Jersey, USA
Questions: Does it continue to play after the controls stop responding? Does the out hyperterm output continue showing status after the controls stop responding?
_________________________
Paul Grzelak
200GB with 48MB RAM, Illuminated Buttons and Digital Outputs

Top
#138414 - 31/01/2003 07:33 Re: HELP half dead RIO [Re: pgrzelak]
Turboegt
new poster

Registered: 30/07/2002
Posts: 24
Loc: Fl, USA
It will keep playing but hyperterm. stops responding after just a few seconds. If I go into Emplode it will find the com port and sync but not in JEmplode.

Top
#138415 - 31/01/2003 09:23 Re: HELP half dead RIO [Re: pgrzelak]
oliver
addict

Registered: 02/04/2002
Posts: 691
i would try this out, check out the How do I stop it from trying to play a bad track? FAQ
_________________________
Oliver mk1 30gb: 129 | mk2a 30gb: 040104126

Top
#138416 - 31/01/2003 09:26 Re: HELP half dead RIO [Re: oliver]
JBjorgen
carpal tunnel

Registered: 19/01/2002
Posts: 3494
Loc: Guadalajara, MX
Notice in the info he posted, it was trying to play 2 different tracks...I don't think that's the issue...
_________________________
~ John

Top
#138417 - 31/01/2003 09:27 Re: HELP half dead RIO [Re: oliver]
Ezekiel
pooh-bah

Registered: 25/08/2000
Posts: 2413
Loc: NH USA
If it is a corrupt file, I found that holding the right button while booting sometimes is enough, it selects the 'next' track before attempting to play the corrupt one. YMMV! Good luck.

-Zeke

Old Hand Post
_________________________
WWFSMD?

Top
#138418 - 31/01/2003 09:30 Re: HELP half dead RIO [Re: JBjorgen]
oliver
addict

Registered: 02/04/2002
Posts: 691
In both of his boot logs, he was trying to play the same song. I think it would be worth a try to load up the empeg without a playlist. Hopefully its something as simple as a bad audio file.
_________________________
Oliver mk1 30gb: 129 | mk2a 30gb: 040104126

Top
#138419 - 31/01/2003 10:15 Re: HELP half dead RIO [Re: oliver]
tfabris
carpal tunnel

Registered: 20/12/1999
Posts: 31160
Loc: Seattle, WA
Also might help to clear the database to see if that's it.

Does this problem still happen with the player unplugged from ethernet? As was mentioned earlier in the thread, the last time I remember hearing this was because a Nimda virus was hammering the player.
_________________________
Tony Fabris

Top
#138420 - 31/01/2003 10:47 Re: HELP half dead RIO [Re: Turboegt]
peter
carpal tunnel

Registered: 13/07/2000
Posts: 4146
Loc: Cambridge, England
then it stops responding

Very odd. It stops responding after exactly thirteen seconds of playback, on two different songs. Does it stop responding if it's not playing?

Peter

Top
#138421 - 31/01/2003 11:57 Re: HELP half dead RIO [Re: peter]
Turboegt
new poster

Registered: 30/07/2002
Posts: 24
Loc: Fl, USA
empeg-car bootstrap v1.02 20001106 (hugo@empeg.com)
If there is anyone present who wants to upgrade the flash, let them speak now,
or forever hold their peace...it seems not. Let fly the Penguins of Linux!

e000 v1.04
Copying kernel...
Calling linux kernel...
Uncompressing Linux..................................... done, booting the kerne
l.
Linux version 2.2.14-rmk5-np17-empeg51 (mac@aphex) (gcc version 2.95.3 20010315
(release)) #17 Wed Jul 24 18:23:20 BST 2002
Processor: Intel StrongARM-1100 revision 11
NetWinder Floating Point Emulator V0.94.1 (c) 1998 Corel Computer Corp.
empeg-car player (hardware revision 9, serial number 30102349)
Command line: mem=16m
Calibrating delay loop... 207.67 BogoMIPS
Memory: 15024k/16M available (964k code, 20k reserved, 372k data, 4k init)
Dentry hash table entries: 2048 (order 2, 16k)
Buffer cache hash table entries: 16384 (order 4, 64k)
Page cache hash table entries: 4096 (order 2, 16k)
POSIX conformance testing by UNIFIX
Linux NET4.0 for Linux 2.2
Based upon Swansea University Computer Society NET3.039
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP
TCP: Hash tables configured (ehash 16384 bhash 16384)
IrDA (tm) Protocols for Linux-2.2 (Dag Brattli)
Linux-IrDA: IrCOMM protocol ( revision:Tue May 18 03:11:39 1999 )
ircomm_tty: virtual tty driver for IrCOMM ( revision:Wed May 26 00:49:11 1999 )
Starting kswapd v 1.5
SA1100 serial driver version 4.27 with no serial options enabled
ttyS00 at 0xf8010000 (irq = 15) is a SA1100 UART
ttyS01 at 0xf8050000 (irq = 17) is a SA1100 UART
ttyS02 at 0xf8030000 (irq = 16) is a SA1100 UART
Signature is 206f6972 'rio '
empeg display initialised.
empeg dsp audio initialised
empeg dsp mixer initialised
empeg dsp initialised
empeg audio-in initialised, CS4231A revision a0
empeg remote control/panel button initialised.
empeg usb initialised, PDIUSBD12 id 1012
empeg state support initialised 0089/88c1 (save to d0005f80).
empeg RDS driver initialised
empeg power-pic driver initialised (first boot)
RAM disk driver initialized: 16 RAM disks of 4096K size
empeg single channel IDE
Probing primary interface...
hda: IBM-DJSA-220, ATA DISK drive
hda: IBM-DJSA-220, ATA DISK drive
hda: IBM-DJSA-220, ATA DISK drive
hda: IBM-DJSA-220, ATA DISK drive
hda: IBM-DJSA-220, ATA DISK drive
hda: IBM-DJSA-220, ATA DISK drive
ide0 at 0x000-0x007,0x038 on irq 6
hda: IBM-DJSA-220, 19077MB w/1874kB Cache, CHS=38760/16/63
empeg-flash driver initialized
smc chip id/revision 0x3349
smc9194.c:v0.12 03/06/96 by Erik Stahlman (erik@vt.edu)

SMC9194: SMC91C94(r:9) at 0x4008000 IRQ:7 INTF:TP MEM:6144b MAC 00:02:d7:26:09:2
d
Partition check:
hda: hda1 < hda5 hda6 > hda2 hda3 hda4
RAMDISK: ext2 filesystem found at block 0
RAMDISK: Loading 320 blocks [1 disk] into ram disk... done.
VFS: Mounted root (ext2 filesystem).
empeg-pump v0.03 (19980601)
Press Ctrl-A to enter pump...VFS: Mounted root (ext2 filesystem) readonly.
change_root: old root has d_count=1
Trying to unmount old root ... okay
Freeing unused kernel memory: 4k init player.cpp : 385:empeg-car 2.00-be
ta13 2002/07/24.
Prolux 4 empeg car - 2.1434 Jul 24 2002
Vcb: 0x4086d000
serial_notify_thread.cpp: 116:@@ N12
serial_notify_thread.cpp: 117:@@ F0x690
serial_notify_thread.cpp: 118:@@ TBelieve
serial_notify_thread.cpp: 119:@@ ACher
serial_notify_thread.cpp: 120:@@ G
serial_notify_thread.cpp: 180:@@ #0 0:08:26
serial_notify_thread.cpp: 170:@@ S0
! mp3_decoder.cpp :1049:Failed to find valid sync after seeking to offset 8096
718, error=0xc0044000
s
No responce

OK, This player has been working fine for about 6 months. Some of my MP3s did get am error when being played by the Rio. Becuase of these errors I dumped everything, used MP3Trim to scan and fix all problems with the files. After testing a few none "errored" files on the Rio I found that this fixed the problems. I only reloaded a very small portion of the drive and then let that part play all the way though its list. What I am trying to say is I have spent a lot of time to make sure the files are good and that the Rio likes then too. As of a few weeks ago I know for 100% that the files were perfect. If they are bad now what can I do to fix then and mainly for did it happen.


Edited by Turboegt (31/01/2003 12:05)

Top
#138422 - 31/01/2003 12:08 Re: HELP half dead RIO [Re: Turboegt]
tfabris
carpal tunnel

Registered: 20/12/1999
Posts: 31160
Loc: Seattle, WA
As of a few weeks ago I know for 100% that the files were perfect. If they are bad now what can I do to fix then and mainly for did it happen.

If it's really been caused by bad files, then there are only the following three possibilities:

- The files were bad to begin with.

- The files were corrupted during the transfer to the player.

- The files became corrupted after they were already on the player.

First situation is an SEP, but you can find out by checking the original copy of these files if you left them on your hard disk after you sent them to the player.

Don't know how to tell the difference between the second and third situations. Also don't know what could have caused the second situation, I've actually never heard of it happening.

The third situation could be caused by disk trouble.
_________________________
Tony Fabris

Top
#138423 - 31/01/2003 17:12 Re: HELP half dead RIO [Re: tfabris]
Turboegt
new poster

Registered: 30/07/2002
Posts: 24
Loc: Fl, USA
OK. The player will not stay "active" long enough to do much of anything. In hypertem. it will only respond for about 5-8 seconds, not long enough for me to clear the database.

HELP HELP HELP

Top
#138424 - 31/01/2003 17:58 Re: HELP half dead RIO [Re: Turboegt]
tfabris
carpal tunnel

Registered: 20/12/1999
Posts: 31160
Loc: Seattle, WA
It stops responding after 5-8 seconds, EVEN IF you quit out of the player application and you're sitting at the shell prompt?
_________________________
Tony Fabris

Top
#138425 - 31/01/2003 18:08 Re: HELP half dead RIO [Re: tfabris]
Turboegt
new poster

Registered: 30/07/2002
Posts: 24
Loc: Fl, USA
Switching to shell-player loop
Starting bash.
no shell!
Shell exit
player.cpp : 385:empeg-car 2.00-beta13 2002/07/24.
! tags.cpp : 61:Failed to open tags (0xc0041002).
Prolux 4 empeg car - 2.1434 Jul 24 2002
Vcb: 0x4086d

Dont I need some other software installed on the player. Software that someone told me to get rid of and go back to the original and can not load anymore.

Top
#138426 - 31/01/2003 18:09 Re: HELP half dead RIO [Re: Turboegt]
pgrzelak
carpal tunnel

Registered: 15/08/2000
Posts: 4859
Loc: New Jersey, USA
Greetings!

When you loaded the software, did you load the developer version? The consumer version does not allow for shell.
_________________________
Paul Grzelak
200GB with 48MB RAM, Illuminated Buttons and Digital Outputs

Top
#138427 - 31/01/2003 18:12 Re: HELP half dead RIO [Re: pgrzelak]
Turboegt
new poster

Registered: 30/07/2002
Posts: 24
Loc: Fl, USA
Great. I loaded the consumer and I do not think I will be able to load the other. The player will not stay active long enough to even get in Emplode anymore. GRRRRRRR

Top
#138428 - 31/01/2003 18:19 Re: HELP half dead RIO [Re: Turboegt]
matthew_k
pooh-bah

Registered: 12/02/2002
Posts: 2296
Loc: Berkeley, California
Flashing doesn't require the player or emplode. Just don't plug it in until it tells you to and you should be fine.

Matthew

Top
#138429 - 31/01/2003 18:19 Re: HELP half dead RIO [Re: Turboegt]
genixia
Carpal Tunnel

Registered: 08/02/2002
Posts: 3411
No, you should always be able to use the upgrade program - it will ask you to reboot and will catch the unit before it boots up.
_________________________
Mk2a 60GB Blue. Serial 030102962 sig.mp3: File Format not Valid.

Top
#138430 - 31/01/2003 18:22 Re: HELP half dead RIO [Re: genixia]
Turboegt
new poster

Registered: 30/07/2002
Posts: 24
Loc: Fl, USA
Oh ya, sorry about that. Can someone link me to the right software to load. Just want to make sure I get it right this time. And thanks for everyones help. I dont want to loosa my little Rio, LOL.

Top
#138431 - 31/01/2003 18:54 Re: HELP half dead RIO [Re: Turboegt]
pgrzelak
carpal tunnel

Registered: 15/08/2000
Posts: 4859
Loc: New Jersey, USA
Greetings!

Just follow the "Latest Software" link in the header, select "Beta Software" and click on the Rio Car (Empeg Mark 2) Developer Image". This, of course, assumes you have a Mark 2 or 2a...
_________________________
Paul Grzelak
200GB with 48MB RAM, Illuminated Buttons and Digital Outputs

Top
#138432 - 31/01/2003 21:47 Re: HELP half dead RIO [Re: Turboegt]
oliver
addict

Registered: 02/04/2002
Posts: 691
Rio Car (Empeg Car Mark 2) Developer image. Load this onto your player to get the shell prompt. Don't Plug in your player to power untill the upgrader tells you to do so. Then use the FAQ i linked to before to clear the playlist from the player. Then let us know what happens.
_________________________
Oliver mk1 30gb: 129 | mk2a 30gb: 040104126

Top
#138433 - 01/02/2003 01:04 Re: HELP half dead RIO [Re: oliver]
Turboegt
new poster

Registered: 30/07/2002
Posts: 24
Loc: Fl, USA

empeg-car bootstrap v1.02 20001106 (hugo@empeg.com)
If there is anyone present who wants to upgrade the flash, let them speak now,
or forever hold their peace...it seems not. Let fly the Penguins of Linux!

e000 v1.04
Copying kernel...
Calling linux kernel...
Uncompressing Linux..................................... done, booting the kerne
l.
Linux version 2.2.14-rmk5-np17-empeg51 (mac@aphex) (gcc version 2.95.3 20010315
(release)) #16 Wed Jul 24 18:19:54 BST 2002
Processor: Intel StrongARM-1100 revision 11
NetWinder Floating Point Emulator V0.94.1 (c) 1998 Corel Computer Corp.
empeg-car player (hardware revision 9, serial number 30102349)
Command line: mem=16m
Calibrating delay loop... 207.67 BogoMIPS
Memory: 15024k/16M available (964k code, 20k reserved, 372k data, 4k init)
Dentry hash table entries: 2048 (order 2, 16k)
Buffer cache hash table entries: 16384 (order 4, 64k)
Page cache hash table entries: 4096 (order 2, 16k)
POSIX conformance testing by UNIFIX
Linux NET4.0 for Linux 2.2
Based upon Swansea University Computer Society NET3.039
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP
TCP: Hash tables configured (ehash 16384 bhash 16384)
IrDA (tm) Protocols for Linux-2.2 (Dag Brattli)
Linux-IrDA: IrCOMM protocol ( revision:Tue May 18 03:11:39 1999 )
ircomm_tty: virtual tty driver for IrCOMM ( revision:Wed May 26 00:49:11 1999 )
Starting kswapd v 1.5
SA1100 serial driver version 4.27 with no serial options enabled
ttyS00 at 0xf8010000 (irq = 15) is a SA1100 UART
ttyS01 at 0xf8050000 (irq = 17) is a SA1100 UART
ttyS02 at 0xf8030000 (irq = 16) is a SA1100 UART
Signature is 206f6972 'rio '
empeg display initialised.
empeg dsp audio initialised
empeg dsp mixer initialised
empeg dsp initialised
empeg audio-in initialised, CS4231A revision a0
empeg remote control/panel button initialised.
empeg usb initialised, PDIUSBD12 id 1012
empeg state support initialised 0089/88c1 (save to d0004d00).
empeg RDS driver initialised
empeg power-pic driver initialised (first boot)
RAM disk driver initialized: 16 RAM disks of 4096K size
empeg single channel IDE
Probing primary interface...
hda: IBM-DJSA-220, ATA DISK drive
hda: IBM-DJSA-220, ATA DISK drive
hda: IBM-DJSA-220, ATA DISK drive
hda: IBM-DJSA-220, ATA DISK drive
hda: IBM-DJSA-220, ATA DISK drive
hda: IBM-DJSA-220, ATA DISK drive
ide0 at 0x000-0x007,0x038 on irq 6
hda: IBM-DJSA-220, 19077MB w/1874kB Cache, CHS=38760/16/63
empeg-flash driver initialized
smc chip id/revision 0x3349
smc9194.c:v0.12 03/06/96 by Erik Stahlman (erik@vt.edu)

SMC9194: SMC91C94(r:9) at 0x4008000 IRQ:7 INTF:TP MEM:6144b MAC 00:02:d7:26:09:2
d
Partition check:
hda: hda1 < hda5 hda6 > hda2 hda3 hda4
RAMDISK: ext2 filesystem found at block 0
RAMDISK: Loading 320 blocks [1 disk] into ram disk... done.
VFS: Mounted root (ext2 filesystem).
empeg-pump v0.03 (19980601)
Press Ctrl-A to enter pump...VFS: Mounted root (ext2 filesystem) readonly.
change_root: old root has d_count=1
Trying to unmount old root ... okay
Freeing unused kernel memory: 4k initempeg init 0.8
I see this is a developer image!
Mounting proc
Mounting first music partition
Tried to mount /dev/hda4 as reiserfs but got error 19
Mounting second music partition
Tried to mount /dev/hdc4 but got error 6
Error mounting partitions (possibly already mounted)
Remounting first music partition read-only
Remounting second music partition read-only
No secondary hard disk
Press 'q' now to go into development mode. You Have Zero Seconds To Com­Starting
player
player.cpp : 385:empeg-car 2.00-beta13 2002/07/24.
q! tags.cpp : 61:Failed to open tags (0xc0041002).

Prolux 4 empeg car - 2.1434 Jul 24 2002
Vcb: 0x4086d000
serial_notify_thread.cpp: 116:@@ N29
serial_notify_thread.cpp: 117:@@ F0x990
serial_notify_thread.cpp: 118:@@ TLet Me See You Pop It
serial_notify_thread.cpp: 119:@@ AGet It Boyz
serial_notify_thread.cpp: 120:@@ G
serial_notify_thread.cpp: 116:@@ N29
serial_notify_thread.cpp: 117:@@ F0x990
serial_notify_thread.cpp: 118:@@ TLet Me See You Pop It
serial_notify_thread.cpp: 119:@@ AGet It Boyz
serial_notify_thread.cpp: 120:@@ G
serial_notify_thread.cpp: 180:@@ #0 0:02:28
serial_notify_thread.cpp: 170:@@ S0
serial_notify_thread.cpp: 180:@@ #990 0:02:29
serial_notify_thread.cpp: 180:@@ #990 0:02:30
q
serial_notify_thread.cpp: 180:@@ #990 0:02:31
serial_notify_thread.cpp: 180:@@ #990 0:02:32
serial_notify_thread.cpp: 180:@@ #990 0:02:33
Restored terminal settings
Remounting first music partition read-only
Remounting second music partition read-only
No secondary hard disk
Player exited normally: 0
Switching to shell-player loop
Starting bash.
empeg:/empeg/bin# rw
empeg:/empeg/bin# rwm
empeg:/empeg/bin# rm/empeg/var/database
bash: rm/empeg/var/database: No such file or directory
empeg:/empeg/bin# rom
empeg:/empeg/bin# ro
empeg:/empeg/bin# exit
logout
Shell exit
Starting player
player.cpp : 385:empeg-car 2.00-beta13 2002/07/24.
! tags.cpp : 61:Failed to open tags (0xc0041002).
Prolux 4 empeg car - 2.1434 Jul 24 2002
Vcb: 0x4086d000
serial_notify_thread.cpp: 116:@@ N29
serial_notify_thread.cpp: 117:@@ F0x990
serial_notify_thread.cpp: 118:@@ TLet Me See You Pop It
serial_notify_thread.cpp: 119:@@ AGet It Boyz
serial_notify_thread.cpp: 120:@@ G
serial_notify_thread.cpp: 116:@@ N29
serial_notify_thread.cpp: 117:@@ F0x990
serial_notify_thread.cpp: 118:@@ TLet Me See You Pop It
serial_notify_thread.cpp: 119:@@ AGet It Boyz
serial_notify_thread.cpp: 120:@@ G
serial_notify_thread.cpp: 180:@@ #990 0:02:33
serial_notify_thread.cpp: 170:@@ S1
serial_notify_thread.cpp: 180:@@ #990 0:02:34
serial_notify_thread.cpp: 180:@@ #990 0:02:35
serial_notify_thread.cpp: 180:@@ #990 0:02:36
serial_notify_thread.cpp: 180:@@ #990 0:02:37
serial_notify_thread.cpp: 180:@@ #990 0:02:38
serial_notify_thread.cpp: 180:@@ #990 0:02:39
serial_notify_thread.cpp: 180:@@ #990 0:02:40
serial_notify_thread.cpp: 180:@@ #990 0:02:41
serial_notify_thread.cpp: 180:@@ #990 0:02:42
serial_notify_thread.cpp: 180:@@ #990 0:02:43
serial_notify_thread.cpp: 180:@@ #990 0:02:44
serial_notify_thread.cpp: 180:@@ #990 0:02:45
serial_notify_thread.cpp: 180:@@ #990 0:02:46
serial_notify_thread.cpp: 180:@@ #990 0:02:47
serial_notify_thread.cpp: 180:@@ #990 0:02:48

Again it stops responding. Is the line rm /empeg/var/database correct. That looks like it is running into a problem there. Also, it seens to be exepting comands fine in the shell. I let it sit for a while, in the shell, and then entered the same comands again and it responded fine. Hope this is a good thing.


Edited by Turboegt (01/02/2003 01:21)

Top
#138434 - 01/02/2003 01:38 Re: HELP half dead RIO [Re: Turboegt]
johnmcd3
enthusiast

Registered: 19/04/2001
Posts: 369
Loc: Seattle, WA (formerly Houston,...
It looks like you left out a space in the line:

"rm/empeg/var/database"

so it did not execute that command correctly. try the same procedure, but with:

"rm /empeg/var/database"

and then try your luck. is the music you have on the drives important? it might be worth trying rebuilding your disks completely. let's try a few more things first though.

John
_________________________
1998 BMW ///M3 30 GB Mk2a, Tuner, and 10 GB backup

Top
Page 1 of 2 1 2 >