Unoffical empeg BBS

Quick Links: Empeg FAQ | Software | RioCar.Org | Hijack | jEmplode | emphatic
Repairs: Repairs | Addons: Eutronix | Cases

Topic Options
#254787 - 22/04/2005 13:49 trio applet only working on server (localhost)
dforsythnet
stranger

Registered: 02/04/2002
Posts: 10
I'm able to run the trio applet on the same box the server is running on. but not able to run it from any other machine. I get a title "tRio Web Font-End" with subtext "finding tRio Server".

Is there some location I have to list what IPs can connect?

for the recond, I'm able to get the applet running on the server using either java 1.4.2 or 1.5.0, using firefox on a linux box FC3.

Here is the log entry from Explorer's Java console.
Code:
 Apr 22, 2005 10:46:11 AM trio.applet.TRioApplet init
INFO: Parameters. trio-server: music.dforsyth.net, rmi-port: 1099
Apr 22, 2005 10:46:11 AM trio.applet.TRioAppletConnectionThread run
INFO: Start of TRioAppletConnectionThread
Apr 22, 2005 10:46:12 AM trio.applet.TRioApplet setServer
INFO: Exporting Remote
Apr 22, 2005 10:46:14 AM trio.applet.TRioApplet setServer
INFO: Remote exception while setting server - server gone down?
java.rmi.ConnectException: Connection refused to host: 127.0.0.1; nested exception is:
java.net.ConnectException: Connection refused: connect
at sun.rmi.transport.tcp.TCPEndpoint.newSocket(Unknown Source)
at sun.rmi.transport.tcp.TCPChannel.createConnection(Unknown Source)
at sun.rmi.transport.tcp.TCPChannel.newConnection(Unknown Source)
at sun.rmi.server.UnicastRef.invoke(Unknown Source)
at trio.TRioServer_Stub.listApplications(Unknown Source)
at trio.applet.TRioApplet.getApplications(Unknown Source)
at trio.applet.TRioApplet.setServer(Unknown Source)
at trio.applet.TRioAppletConnectionThread.establishConnection(Unknown Source)
at trio.applet.TRioAppletConnectionThread.run(Unknown Source)
Caused by: java.net.ConnectException: Connection refused: connect
at java.net.PlainSocketImpl.socketConnect(Native Method)
at java.net.PlainSocketImpl.doConnect(Unknown Source)
at java.net.PlainSocketImpl.connectToAddress(Unknown Source)
at java.net.PlainSocketImpl.connect(Unknown Source)
at java.net.SocksSocketImpl.connect(Unknown Source)
at java.net.Socket.connect(Unknown Source)
at java.net.Socket.connect(Unknown Source)
at java.net.Socket.<init>(Unknown Source)
at java.net.Socket.<init>(Unknown Source)
at sun.rmi.transport.proxy.RMIDirectSocketFactory.createSocket(Unknown Source)
at sun.rmi.transport.proxy.RMIMasterSocketFactory.createSocket(Unknown Source)
... 9 more
Exception in thread "Thread-17" java.lang.NullPointerException
at trio.applet.TRioApplet.disposeNavigationPanel(Unknown Source)
at trio.applet.TRioApplet.setServer(Unknown Source)
at trio.applet.TRioAppletConnectionThread.checkConnection(Unknown Source)
at trio.applet.TRioAppletConnectionThread.run(Unknown Source)


Top
#254788 - 24/04/2005 15:36 Re: trio applet only working on server (localhost) [Re: dforsythnet]
pauln
enthusiast

Registered: 03/12/2001
Posts: 332
Loc: UK
Try editing trio.xml and change:

<rmi create-registry="true"/>

to:

<rmi create-registry="true" host-name="xxxx"/>

Where xxxx is the ip address of the box that tRio is running on.

Cheers
Paul

Top
#254789 - 26/04/2005 13:47 Re: trio applet only working on server (localhost) [Re: pauln]
dforsythnet
stranger

Registered: 02/04/2002
Posts: 10
Thanks, adding the host part solved my problem.

Also running the applit on java 1.5.0 the tabs do not work, I have noticed some other postings reporting this problem.

Top
#254790 - 10/04/2007 13:54 Re: trio applet only working on server (localhost) [Re: pauln]
BaBa
new poster

Registered: 18/01/2002
Posts: 11
Loc: Ventura, CA USA
This is an awesome app!!! I have 6 units and would love to be able to control them using my PSP.

Quote:
I'm able to run the trio applet on the same box the server is running on. but not able to run it from any other machine.


I have this problem as well, and tried this suggestion

Quote:
<rmi create-registry="true" host-name="xxxx"/>


and substituted xxxx with 192.168.0.3, the static ip of my server. - but it didn't work for me. I can only view the front-end on the local machine using the following URL http://localhost:8090/trio-html

I cannot even use the local machine's ip address on the local machine (http://192.168.0.3:8090/trio-htm)

I'm running WinXP SP2, tRio 0.1.6, Java 1.42. I've got no software firewall running.
Any suggestions?

Thank You!!!

Top