Unoffical empeg BBS

Quick Links: Empeg FAQ | Software | RioCar.Org | Hijack | jEmplode | emphatic
Repairs: Repairs | Addons: Eutronix | Cases

Topic Options
#283960 - 04/07/2006 01:47 Stupid, stupid Java
YNaught
new poster

Registered: 28/01/2006
Posts: 13
Or maybe it's me. Whatever the case, I don't know the first thing about debugging Java installs, so am at a loss.

I have running now: Ampache, ssdp.pl, NFS, DHCP, but I have not been able to get trio to run.

Gentoo easily installed sun java 1.4.2_10 but with that I get:
bill ~ # tail /var/log/trio.log
STARTED tRio Mon Jul 3 03:05:00 CDT 2006
Error occurred during initialization of VM
java/lang/NoClassDefFoundError: java/lang/Object

With great trouble, I found 1.4.2_06 but it did not make things better; I got the same error in trio.log but if I tried to run java from command line I got an error similar to what's in the trio.log.

I tried blackdown 1.4.2.03 but did not have success.

I've tried the JREs and the SDKs.

I suspect It's not the java version at all but some subtle (or not) configuration issue. Here's more information from my system:

bill ~ # /usr/local/trio/bin/trio.sh check
Hello ...
Defaulting TRIO_HOME to /usr/local/trio
RunCommand = /opt/sun-jdk-1.4.2.10/bin/java -Djava.net.preferIPv4Stack=true -Dtrio.home=/usr/local/trio -Xbootclasspath:/usr/local/trio/lib/pja-mod.jar:/opt/sun-jdk-1.4.2.10/lib/rt.jar -Dawt.toolkit=com.eteks.awt.PJAToolkit -Djava.awt.graphicsenv=com.eteks.java2d.PJAGraphicsEnvironment -Djava.awt.fonts=/opt/sun-jdk-1.4.2.10/lib/fonts -Djava.util.logging.config.file=/usr/local/trio/linux-logging.properties -cp /usr/local/trio/lib/commons-beanutils.jar:/usr/local/trio/lib/commons-collections.jar:/usr/local/trio/lib/commons-digester.jar:/usr/local/trio/lib/commons-lang.jar:/usr/local/trio/lib/commons-logging.jar:/usr/local/trio/lib/jrclient.jar:/usr/local/trio/lib/jrcommon.jar:/usr/local/trio/lib/jrutil.jar:/usr/local/trio/lib/trio-0.1.6.jar:/usr/local/trio/lib/trio-applet-0.1.6.jar:/usr/local/trio/lib/xmlrpc.jar:/opt/sun-jdk-1.4.2.10/lib/tools.jar trio.TRioServer -c/usr/local/trio/trio.xml
Checking arguments to tRio:
TRIO_HOME = /usr/local/trio
TRIO_CONF = /usr/local/trio/trio.xml
TRIO_RUN = /var/run
TRIO_PID = /var/run/trio.pid
TRIO_CONSOLE = /var/log/trio.log
JAVA_HOME = /opt/sun-jdk-1.4.2.10
JAVA_OPTIONS = -Djava.net.preferIPv4Stack=true -Dtrio.home=/usr/local/trio -Xbootclasspath:/usr/local/trio/lib/pja-mod.jar:/opt/sun-jdk-1.4.2.10/lib/rt.jar -Dawt.toolkit=com.eteks.awt.PJAToolkit -Djava.awt.graphicsenv=com.eteks.java2d.PJAGraphicsEnvironment -Djava.awt.fonts=/opt/sun-jdk-1.4.2.10/lib/fonts -Djava.util.logging.config.file=/usr/local/trio/linux-logging.properties
JAVA = /opt/sun-jdk-1.4.2.10/bin/java
JAVA VERSION =
CLASSPATH = /usr/local/trio/lib/commons-beanutils.jar:/usr/local/trio/lib/commons-collections.jar:/usr/local/trio/lib/commons-digester.jar:/usr/local/trio/lib/commons-lang.jar:/usr/local/trio/lib/commons-logging.jar:/usr/local/trio/lib/jrclient.jar:/usr/local/trio/lib/jrcommon.jar:/usr/local/trio/lib/jrutil.jar:/usr/local/trio/lib/trio-0.1.6.jar:/usr/local/trio/lib/trio-applet-0.1.6.jar:/usr/local/trio/lib/xmlrpc.jar:/opt/sun-jdk-1.4.2.10/lib/tools.jar
RUN_CMD = /opt/sun-jdk-1.4.2.10/bin/java -Djava.net.preferIPv4Stack=true -Dtrio.home=/usr/local/trio -Xbootclasspath:/usr/local/trio/lib/pja-mod.jar:/opt/sun-jdk-1.4.2.10/lib/rt.jar -Dawt.toolkit=com.eteks.awt.PJAToolkit -Djava.awt.graphicsenv=com.eteks.java2d.PJAGraphicsEnvironment -Djava.awt.fonts=/opt/sun-jdk-1.4.2.10/lib/fonts -Djava.util.logging.config.file=/usr/local/trio/linux-logging.properties -cp /usr/local/trio/lib/commons-beanutils.jar:/usr/local/trio/lib/commons-collections.jar:/usr/local/trio/lib/commons-digester.jar:/usr/local/trio/lib/commons-lang.jar:/usr/local/trio/lib/commons-logging.jar:/usr/local/trio/lib/jrclient.jar:/usr/local/trio/lib/jrcommon.jar:/usr/local/trio/lib/jrutil.jar:/usr/local/trio/lib/trio-0.1.6.jar:/usr/local/trio/lib/trio-applet-0.1.6.jar:/usr/local/trio/lib/xmlrpc.jar:/opt/sun-jdk-1.4.2.10/lib/tools.jar trio.TRioServer -c/usr/local/trio/trio.xml

tRio running pid=13676

bill ~ # java -version
java version "1.4.2_10"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_10-b03)
Java HotSpot(TM) Client VM (build 1.4.2_10-b03, mixed mode)
bill ~ # which java
/opt/sun-jdk-1.4.2.10/bin/java

So, are there versions of java known to work or not work with trio?

Is there an alternative to trio (preferably NOT java-based) that is as well designed? Specifically, I rather hated the orignal firmware, in that if you picked out some music it stopped playing what was on and played the new selection (rather than just adding it to the playlist)... duh.

Would tRio 1.7 behave any better? Maybe I'll try that in the meantime.

Thanks in advance,

Adam

Top
#283961 - 04/07/2006 11:52 Re: Stupid, stupid Java [Re: YNaught]
andy
carpal tunnel

Registered: 10/06/1999
Posts: 5672
Loc: Wivenhoe, Essex, UK
Try validating that your Java install is actuall working, but running something Java based that isn't tRio. For example, try compiling and running the typical "hello world" app:

http://www.javacoffeebreak.com/java101/java101.html
_________________________
Remind me to change my signature to something more interesting someday

Top
#283962 - 04/07/2006 11:56 Re: Stupid, stupid Java [Re: YNaught]
andy
carpal tunnel

Registered: 10/06/1999
Posts: 5672
Loc: Wivenhoe, Essex, UK
Also, I assume you have read this bit in the troubleshooting section of the install instructions:

"Getting "java/lang/NoClassDefFoundError: java/lang/Object"
This is because java can’t find the “rt.jar” file specified by JAVA_HOME\lib\rt.jar.

Check that your JAVA_HOME setting is correct in your trio.bat or script
If you’ve installed the Java SDK rather than just the runtime, rt.jar might be in JAVA_HOME\jre\lib\rt.jar. If so, change your script/batch file."
_________________________
Remind me to change my signature to something more interesting someday

Top