Unoffical empeg BBS

Quick Links: Empeg FAQ | Software | RioCar.Org | Hijack | jEmplode | emphatic
Repairs: Repairs | Addons: Eutronix | Cases

Page 1 of 2 1 2 >
Topic Options
#160849 - 09/05/2003 18:01 empeg self started while in my docking station
Laura
pooh-bah

Registered: 16/06/2000
Posts: 1682
Loc: Metamora, IN
I was thinking that it would be nice to be listening to music when my empeg started playing while in my docking station on top of my desk. Interesting

Has anyone else had this happen? The cats weren't near it so they aren't the guilty ones (this time) of the crime.
_________________________
Laura

MKI #017/90

whatever

Top
#160850 - 09/05/2003 18:19 Re: empeg self started while in my docking station [Re: Laura]
Tim
veteran

Registered: 25/04/2000
Posts: 1487
Loc: Arizona
Psychokenesis maybe? Spooky

Top
#160851 - 09/05/2003 18:28 Re: empeg self started while in my docking station [Re: Tim]
pgrzelak
carpal tunnel

Registered: 15/08/2000
Posts: 4859
Loc: New Jersey, USA
Yes, I have had it happen occasionally. No IR devices anywhere near. I thought it was a power spike or noisy environment, but never really traced it out.
_________________________
Paul Grzelak
200GB with 48MB RAM, Illuminated Buttons and Digital Outputs

Top
#160852 - 09/05/2003 18:35 Re: empeg self started while in my docking station [Re: Laura]
mlord
carpal tunnel

Registered: 29/08/2000
Posts: 14077
Loc: Canada
It's not related to the dock -- others have been reporting this for many many months now. Dunno what causes it yet.

Cheers

Top
#160853 - 09/05/2003 18:38 Re: empeg self started while in my docking station [Re: pgrzelak]
Laura
pooh-bah

Registered: 16/06/2000
Posts: 1682
Loc: Metamora, IN
I have no IR devices nearby either. I have to turn my TV on with a pen, no remote and the on button fell off. It would have scared me if it had happened in the middle of the night since it's in my bedroom

I am running the latest version of software with no hijack (sorry Mark, I just haven't gotten around to it).
_________________________
Laura

MKI #017/90

whatever

Top
#160854 - 09/05/2003 18:40 Re: empeg self started while in my docking station [Re: Laura]
mlord
carpal tunnel

Registered: 29/08/2000
Posts: 14077
Loc: Canada
I am running the latest version of software with no hijack (sorry Mark, I just haven't gotten around to it).
Music to my eyes! This is the first definite report of it happening WITHOUT hijack installed! And it's in Car-Mode (right?), just like all of the others! Put this thread into the Bug Reports forum, please!

Cheers ...

Top
#160855 - 09/05/2003 18:57 Re: empeg self started while in my docking station [Re: mlord]
Laura
pooh-bah

Registered: 16/06/2000
Posts: 1682
Loc: Metamora, IN
Gee, and I thought you would be mad but instead you're happy I'm not running it.

(decides that Mark doesn't like her any more )
_________________________
Laura

MKI #017/90

whatever

Top
#160856 - 09/05/2003 19:05 Re: empeg self started while in my docking station [Re: Laura]
mlord
carpal tunnel

Registered: 29/08/2000
Posts: 14077
Loc: Canada
>decides that Mark doesn't like her any more

Naw.. you're just snuggly as ever to me! Mostly I'm happy cuz my ADSL link just came back on-line two minutes ago!

Cheers

Top
#160857 - 09/05/2003 19:11 Re: empeg self started while in my docking station [Re: mlord]
Laura
pooh-bah

Registered: 16/06/2000
Posts: 1682
Loc: Metamora, IN
Mostly I'm happy cuz my ADSL link just came back on-line two minutes ago!


That would make me happy too if mine went down.
_________________________
Laura

MKI #017/90

whatever

Top
#160858 - 09/05/2003 19:15 Re: empeg self started while in my docking station [Re: pgrzelak]
Laura
pooh-bah

Registered: 16/06/2000
Posts: 1682
Loc: Metamora, IN
Paul, when yours did this did you notice the volume keeps showing on the screen every 30 seconds or so by itself? I just posted this to the bug forum.
_________________________
Laura

MKI #017/90

whatever

Top
#160859 - 10/05/2003 04:43 Re: empeg self started while in my docking station [Re: Laura]
pgrzelak
carpal tunnel

Registered: 15/08/2000
Posts: 4859
Loc: New Jersey, USA
Greetings!

Not volume, no. When it does happen, it seems to just be a poweron. It can happen in both car and AC modes, though. Before I had the dock, I had this happen in AC mode too.

There is another thread where Tony mentions that it could be a noisy IR input. I think I agree with that. I have had other symptoms of phantom pushes, but mine are always alternating source (aux/player) very quickly. It stops on a button press.

There are a few threads about this one too - but they all seem to be the same general symptom: spurious IR or control signals. Maybe even the player waking in the car might be tied to this as well...

I suspect either some debounce logic, or the IR input is picking up / generating noise. One of these days (it happens too rarely for me to test with any consistancy), I will put the IR debug up, to see if it is "seeing" any coherent (or incoherent) signals.

Is there any good way to test if the IR receiver is starting to deteriorate somehow?
_________________________
Paul Grzelak
200GB with 48MB RAM, Illuminated Buttons and Digital Outputs

Top
#160860 - 10/05/2003 05:02 Re: empeg self started while in my docking station [Re: pgrzelak]
Laura
pooh-bah

Registered: 16/06/2000
Posts: 1682
Loc: Metamora, IN
Last night I ended up pulling it out of the dock because it started playing 10 mintues after I powered it off. This morning I pushed it back into the docking station and it started right up. I don't think this has anything to do with IR signals.
_________________________
Laura

MKI #017/90

whatever

Top
#160861 - 10/05/2003 05:13 Re: empeg self started while in my docking station [Re: Laura]
Laura
pooh-bah

Registered: 16/06/2000
Posts: 1682
Loc: Metamora, IN
I stuck it back in and powered it off and it took 4 minutes for it to start playing again. I'm going to have to test it in the van, as soon as the rain ever stops, to see if this behavior is going to happen in the sled also. This could be a big problem if it won't stay turned off now for some reason.
_________________________
Laura

MKI #017/90

whatever

Top
#160862 - 10/05/2003 06:35 Re: empeg self started while in my docking station [Re: Laura]
peter
carpal tunnel

Registered: 13/07/2000
Posts: 4153
Loc: Cambridge, England
Has anyone else had this happen? The cats weren't near it so they aren't the guilty ones (this time) of the crime.
I still suspect the cats. This happens to a friend of mine, too (1.03, no Hijack), and cats are the only common factor that I can see. I reckon it's their invisible infra-red mind control rays... you know, the thing where they walk into the room and suddenly, without anything Shannon would recognise as information transfer, it's "Oooh, Lottie's hungry"...

Peter

Top
#160863 - 10/05/2003 06:52 Re: empeg self started while in my docking station [Re: peter]
Laura
pooh-bah

Registered: 16/06/2000
Posts: 1682
Loc: Metamora, IN
cats are the only common factor that I can see. I reckon it's their invisible infra-red mind control rays...


Maybe that is it because they were in the room everytime, just not near the empeg controls
_________________________
Laura

MKI #017/90

whatever

Top
#160864 - 10/05/2003 09:21 Re: empeg self started while in my docking station [Re: Laura]
tfabris
carpal tunnel

Registered: 20/12/1999
Posts: 31286
Loc: Seattle, WA
I don't think this has anything to do with IR signals.
If it is related to IR signals, I don't think it would be "stray IR" like you're thinking. It would be more like: Something wrong the circuitry causes the IR sensor to behave as though it's getting stray signals even when there are none.

Question about the Mk2a volume control: It's optical, right? Is it infrared? Maybe the casing of the encoder leaks a bit...
_________________________
Tony Fabris

Top
#160865 - 10/05/2003 09:28 Re: empeg self started while in my docking station [Re: tfabris]
AndrewT
old hand

Registered: 16/02/2002
Posts: 867
Loc: Oxford, UK
Unless I'm mistaken, sometimes my encoder seems to rest at the point where even the slightest touch causes the volume bar to display. Perhaps it's something as simple as this?

Top
#160866 - 10/05/2003 10:59 Re: empeg self started while in my docking station [Re: Laura]
mlord
carpal tunnel

Registered: 29/08/2000
Posts: 14077
Loc: Canada
Ya know, Laura, if you'd only break down and install Hijack, this behaviour should cease, at least while docked.

If I recall correctly, people only observe this when the player is running in DC/Car mode.. (at this point, seven people churp in with reports of it on AC/Home, right?).

Cheers

Top
#160867 - 10/05/2003 11:09 Re: empeg self started while in my docking station [Re: mlord]
pgrzelak
carpal tunnel

Registered: 15/08/2000
Posts: 4859
Loc: New Jersey, USA
Well, one...

I would have it sitting in the cube at work (before the docking station), so it was fully in AC mode, and it would suddenly power-up.
_________________________
Paul Grzelak
200GB with 48MB RAM, Illuminated Buttons and Digital Outputs

Top
#160868 - 10/05/2003 11:14 Re: empeg self started while in my docking station [Re: mlord]
peter
carpal tunnel

Registered: 13/07/2000
Posts: 4153
Loc: Cambridge, England
At this point, seven people churp in with reports of it on AC/Home right?
The friend of mine that this happens to, has it happen on AC power.

If we assume, for the sake of argument, that domestic cats do not, in fact, spontaneously emit valid consumer IR pulse-trains, then my money is on some kind of capacitative glitching on the display board, building up very slowly but eventually causing the PIC to register an instantaneous top-button press. Perhaps if front-panel buttons were debounced a bit more it could be fixed in software?

Peter

Top
#160869 - 10/05/2003 11:37 Re: empeg self started while in my docking station [Re: mlord]
Laura
pooh-bah

Registered: 16/06/2000
Posts: 1682
Loc: Metamora, IN
It's happening in AC power on mine also. I guess I'm going to have to keep it unplugged or pull it slightly out of the sled unless I want to listen to it. It's not random on mine now, it's happening constantly. Took a little over an hour this time to come back on but it won't stay off.
_________________________
Laura

MKI #017/90

whatever

Top
#160870 - 10/05/2003 12:02 Re: empeg self started while in my docking station [Re: peter]
tfabris
carpal tunnel

Registered: 20/12/1999
Posts: 31286
Loc: Seattle, WA
building up very slowly but eventually causing the PIC to register an instantaneous top-button press
Or, in Laura's case, a volume-knob turn. Remeber that any IR command or button press will wake up the player.

Here's an idea. Not a solution to the hardware problem, but a band-aid that might be useful: An option in Hijack (perhaps in config.ini) which says that only a specified set of button presses or events can wake up the player from standby, it ignores all other commands. For instance, tell it that only a top-button press can wake up the player, or only a knob press, or a press of the power button on the Rio remote, etc.

That way, if it's random commands (for whatever reason) causing the wake-ups, you'd eliminate 99 percent of them.

Is that even possible to do?
_________________________
Tony Fabris

Top
#160871 - 10/05/2003 12:46 Re: empeg self started while in my docking station [Re: tfabris]
tman
carpal tunnel

Registered: 24/12/2001
Posts: 5528
I don't see why it shouldn't be possible. The kernel knows when the display is off and it can just swallow all IR commands apart from say the power button one. And once it gets that one then it will do the normal thing and allow everything to pass.

- Trevor

Top
#160872 - 10/05/2003 13:50 Re: empeg self started while in my docking station [Re: tfabris]
Laura
pooh-bah

Registered: 16/06/2000
Posts: 1682
Loc: Metamora, IN
How would I go about doing that? Or in other words exactly what would I need to put in config.ini?
_________________________
Laura

MKI #017/90

whatever

Top
#160873 - 10/05/2003 15:17 Re: empeg self started while in my docking station [Re: Laura]
tfabris
carpal tunnel

Registered: 20/12/1999
Posts: 31286
Loc: Seattle, WA
How would I go about doing that? Or in other words exactly what would I need to put in config.ini?
Something like this might work:

[Dear Mark]
Please=Add this feature for me.
I'd be=eternally grateful.
_________________________
Tony Fabris

Top
#160874 - 10/05/2003 15:32 Re: empeg self started while in my docking station [Re: tfabris]
Laura
pooh-bah

Registered: 16/06/2000
Posts: 1682
Loc: Metamora, IN
[Dear Mark]
Please=Add this feature for me.
I'd be=eternally grateful.


Then I'd even put hijack back on it

_________________________
Laura

MKI #017/90

whatever

Top
#160875 - 10/05/2003 18:02 Re: empeg self started while in my docking station [Re: Laura]
mlord
carpal tunnel

Registered: 29/08/2000
Posts: 14077
Loc: Canada
Naw, let's find/fix the bug instead.

Since Laura can reproduce this bug very easily, and she's more than competent technically, this oughta be a breeze!

Could you hook up a notebook computer to the serial port, install Hijack, and set "ir_debug=1" in the [hijack] section of config.ini ?

Then just put it in standby, and wait for it to wake up again.
The serial log will tell the story for us. Post it.

Thanks!

Top
#160876 - 10/05/2003 18:16 Re: empeg self started while in my docking station [Re: mlord]
belezeebub
addict

Registered: 11/01/2001
Posts: 579
Cheap Way to see if its an IR signel or something else... Cover the IR sensor with a Piece of Electrical Tape , if it still turns it self back on then its not a IR signel :0
_________________________
______________________________________ Do not meddle in the affairs of Network Administrators, for they are subtle and quick to anger. ______________________________________ Worlds Lamest Wb Site (mine) http://home.comcast.net/~jlipchitz/

Top
#160877 - 10/05/2003 18:58 Re: empeg self started while in my docking station [Re: mlord]
Laura
pooh-bah

Registered: 16/06/2000
Posts: 1682
Loc: Metamora, IN
Can I do it using my desktop computer?
_________________________
Laura

MKI #017/90

whatever

Top
#160878 - 10/05/2003 19:52 Re: empeg self started while in my docking station [Re: Laura]
tfabris
carpal tunnel

Registered: 20/12/1999
Posts: 31286
Loc: Seattle, WA
Can I do it using my desktop computer?
Any computer that'll connect with hyperterminal, as detailed here, will do.
_________________________
Tony Fabris

Top
Page 1 of 2 1 2 >