Unoffical empeg BBS

Quick Links: Empeg FAQ | Software | RioCar.Org | Hijack | jEmplode | emphatic
Repairs: Repairs | Addons: Eutronix | Cases

Topic Options
#11039 - 07/07/2000 16:27 Clone the destroyer - WARNING
Big John
member

Registered: 05/10/1999
Posts: 126
Loc: Hants, UK.
Hi,

Just a warning to MK2 users who intend to use the clone tool, I just did and it toasted my MK1's contents with the test data on the MK2!!!! The panel displayed the source and destination devices correctly i.e. source=MK1, destination=MK2, then proceeded to image the data. It crabbed out after 15 mins with an error -1!!! Checked to see what it had done and it's wipped the precious 20G off my MK1 and partialy copied the 1G of test data I placed on the MK2 the other evening. I'm not a happy bunny...

Okay, I was using emplode V11b off the distribution disk that came with the MK2 and consumer beta11A on the MK1 and developer beta11D on the MK2. I know I still have all the data on the HD, but all those playlists!!

I'm going to bed.



_________________________________________
John, (MK1 114-20G, MK2 15-36G).
_________________________
[color:yellow]_________________________________________John, (MK1 #114-20G, MK2 #15-36G).</font color=yellow>

Top
#11040 - 07/07/2000 16:29 Re: Clone the destroyer - WARNING [Re: Big John]
altman
carpal tunnel

Registered: 19/05/1999
Posts: 3449
Loc: Palo Alto, CA
This is very strange; are you using the latest clone tool on the website?

Hugo



Top
#11041 - 07/07/2000 16:38 Re: Clone the destroyer - WARNING [Re: Big John]
Henno
addict

Registered: 15/07/1999
Posts: 568
Loc: Meije, Netherlands
time to update your bio ?
"Dislikes: My empeg when it breaks down (not very often)!
"

Henno
mk2 nr 6
_________________________
Henno mk2 [orange]6 [/orange]nr 6

Top
#11042 - 07/07/2000 16:44 Re: Clone the destroyer - WARNING [Re: altman]
Big John
member

Registered: 05/10/1999
Posts: 126
Loc: Hants, UK.
Hi,

In reply to:

This is very strange; are you using the latest clone tool on the website?


Having looked at the download page it appears not. I scanned the list of files available and didn't notice the 11D version of emplode. If you look at the description of it, it reads: -

A complete setup program for the Windows software included in the beta11d release. This is functionally identical to the version of empegClone provided here previously and the 11b version of emplode. You do not need to download this release if you have previously downloaded the empegClone executable for beta11d. Please note that you must synchronise your Mark 1 player with emplode version 11a or later in order to use empegClone.

and I'm so used to seeing: -

emplode PC software (Win32)
Download Now (2224943 bytes)


As I said in my posting it was emplode beta11B I was using. I read the text as meaning I didn't need version beta11D if I already had beta11B. Anyway, it's history and I'm still going to bed...



_________________________________________
John, (MK1 114-20G, MK2 15-36G).

_________________________
[color:yellow]_________________________________________John, (MK1 #114-20G, MK2 #15-36G).</font color=yellow>

Top
#11043 - 07/07/2000 16:50 Re: Clone the destroyer - WARNING [Re: Henno]
Big John
member

Registered: 05/10/1999
Posts: 126
Loc: Hants, UK.
Hi,

I guess I'm passed being an unpaid beta tester. I don't really mean that, sometimes it seems like an uphill struggle cutting through the hard edge of MP3 technology - I remember the days... Yawn!

Regards,


_________________________________________
John, (MK1 114-20G, MK2 15-36G).
_________________________
[color:yellow]_________________________________________John, (MK1 #114-20G, MK2 #15-36G).</font color=yellow>

Top
#11044 - 07/07/2000 17:14 Re: Clone the destroyer - WARNING [Re: Big John]
Big John
member

Registered: 05/10/1999
Posts: 126
Loc: Hants, UK.
An add to my post:

When I synchronised to the MK1, from what I can tell most of the playlists and a lot...of tracks have been deposited in the un-attached folder - what a mess.



_________________________________________
John, (MK1 114-20G, MK2 15-36G).
_________________________
[color:yellow]_________________________________________John, (MK1 #114-20G, MK2 #15-36G).</font color=yellow>

Top
#11045 - 07/07/2000 17:55 Re: Clone the destroyer - WARNING [Re: Big John]
rob
carpal tunnel

Registered: 21/05/1999
Posts: 5315
Loc: Cambridge UK
From the Announce forum:

"there's a fixed empegClone file available at the usual spot. There were some problems with the one included previously that could cause some fairly heinous problems."

I think you experienced those fairly heinous problems. Any "lost" tracks should be in Unattached Items, but obviously reorganising them could be a pain.

Sorry for the hassle. Obviously we didn't experience this problem in our original testing, but we did fix the problem as soon as it was reported.

Rob



Top
#11046 - 07/07/2000 19:08 Re: Clone the destroyer - WARNING [Re: rob]
Dredd
enthusiast

Registered: 12/11/1999
Posts: 261
Loc: Bay Area, California
True, but ALSO remember that you specifically DON'T want this to be the official forum. Probably could've been labeled better on the site (as a different post indicates).


Top
#11047 - 08/07/2000 00:37 Re: Clone the destroyer - WARNING [Re: altman]
Big John
member

Registered: 05/10/1999
Posts: 126
Loc: Hants, UK.
Hi,

In reply to:

This is very strange; are you using the latest clone tool on the website?


Downloaded the latest version from the web site under the beta11D block and installed it, just out of curiosity I started another clone using the latest version of the clone tool. It crabbed out with a -2 error after one block on the progress bar! Presumably, this is the tested version?


_________________________________________
John, (MK1 114-20G, MK2 15-36G).

_________________________
[color:yellow]_________________________________________John, (MK1 #114-20G, MK2 #15-36G).</font color=yellow>

Top
#11048 - 08/07/2000 01:53 Re: Clone the destroyer - WARNING [Re: Dredd]
mac
addict

Registered: 20/05/1999
Posts: 411
Loc: Cambridge, UK
True, but ALSO remember that you specifically DON'T want this to be the official forum. Probably could've been labeled better on the site (as a different post indicates).

It was mentioned on our website, admitedly only in the downloads section. We can't really put every little beta release on the front page.

When I found this bug I really was surprised that it hadn't bitten many people. When I was investigating the bug I swapped a few versions of the tool with one Mark 2 owner who could very quickly repair his Mark 1 by just moving everything out of Unattached items each time it broke.

As for us not wanting this to be an official forum, Rob and I discussed the announcement of Mark 2 beta software this week. We felt that the vast majority of current Mark 2 owners do read this BBS and therefore it was a good place to announce.

We always plan to announce using alternative mechanisms but we usually want to make sure the release is stable first. We announce it here and then wait. Unfortunately, we wait too long and think we can sort out the bugs and release a new one and then announce _that_ more widely. Hence, I can't remember the last one that was announced more widely :-)

The latest version is always available from the web site.

We intended to email all Mark 2 customers with details of the available upgrade but I didn't feel that beta11d was enough of a step forward.

However, given the extreme nature of this bug I now believe that we should have announced the new version of empegClone using email to all Mark 2 owners.


--
Mike Crowe
I may not be speaking on behalf of empeg above :-)
_________________________
--
Mike Crowe

Top
#11049 - 08/07/2000 02:00 Re: Clone the destroyer - WARNING [Re: Big John]
mac
addict

Registered: 20/05/1999
Posts: 411
Loc: Cambridge, UK
The whole situation was overcomplicated by me releasing just an executable for empegClone since I wanted to get it out as quickly as possible.

Since we were sending out CDs with units I had to roll empegClone into the setup program and thus created emplode-beta11d.

I decided that people would be more likely to upgrade to it if I placed that on the website instead of the empegClone executable.

I was worried that people would spend time downloading it and then discover that nothing had changed (functionally) if they had already downloaded the empegClone executable.

Whilst what I wrote makes sense to me, I probably could have put it better. It had been a long day and it was nearly tomorrow. :-)

So, John, does it now work correctly? The error reporting in empegClone is rather bad unfortunately. It does make assumptions about the presence of certain files without having the capability of creating them like emplode does. I intend to do some work on it when I get the chance to ensure that the error message for this case is much better (although it probably still won't create the files itself).

--
Mike Crowe
I may not be speaking on behalf of empeg above :-)
_________________________
--
Mike Crowe

Top
#11050 - 08/07/2000 07:35 Re: Clone the destroyer - WARNING [Re: mac]
Big John
member

Registered: 05/10/1999
Posts: 126
Loc: Hants, UK.
Hi,

So, John, does it now work correctly? The error reporting in empegClone is rather bad unfortunately. It does make assumptions about the presence of certain files without having the capability of creating them like emplode does. I intend to do some work on it when I get the chance to ensure that the error message for this case is much better (although it probably still won't create the files itself).

Well as I posted, I did try the beta11D version of the clone tool and it barfed with an error -2. I've spent some time restructuring my HD file structures to simply do a drag-drop. I'll be giving that tool a wide berh I think, stick with what I know works.

Regards,

_________________________________________
John, (MK1 114-20G, MK2 15-36G).
_________________________
[color:yellow]_________________________________________John, (MK1 #114-20G, MK2 #15-36G).</font color=yellow>

Top
#11051 - 08/07/2000 08:38 Re: Clone the destroyer - WARNING [Re: Big John]
mac
addict

Registered: 20/05/1999
Posts: 411
Loc: Cambridge, UK
I believe that the -2 error is because of the lack of a config.ini file on your Mark 1 (even though I would have expected you to have one on your player even before the latest versions of emplode created it). This should have been solved by resynchronising the Mark 1 with beta11d of emplode. If you did this then the error must be due to something else which I hadn't considered.

I'm sorry that you don't feel you have the confidence in the clone tool to try it again.

--
Mike Crowe
I may not be speaking on behalf of empeg above :-)
_________________________
--
Mike Crowe

Top
#11052 - 08/07/2000 13:25 Re: Clone the destroyer - WARNING [Re: mac]
Big John
member

Registered: 05/10/1999
Posts: 126
Loc: Hants, UK.
Hi Mike,

I believe that the -2 error is because of the lack of a config.ini file on your Mark 1 (even though I would have expected you to have one on your player even before the latest versions of emplode created it). This should have been solved by resynchronising the Mark 1 with beta11d of emplode. If you did this then the error must be due to something else which I hadn't considered.

It didn't barf straight away, it was quite happy imaging for a while until I left it.

There was a config.ini on my MK1, saying that, there was one, I think I removed or edited it when the 4800 baud support was introduced, whatever.

I'm sorry that you don't feel you have the confidence in the clone tool to try it again.

Not a lot of point now, same amount of data to shift, so I thought I'd lay out my MP3 directory structure and do a drag-n-drop, been running for 9.5 hours now and from the status bar about 45% complete.

Regards,


_________________________________________
John, (MK1 114-20G, MK2 15-36G).
_________________________
[color:yellow]_________________________________________John, (MK1 #114-20G, MK2 #15-36G).</font color=yellow>

Top
#11053 - 08/07/2000 15:41 Re: Clone the destroyer - WARNING [Re: Big John]
jfranke
member

Registered: 09/06/1999
Posts: 124
Just to add, exactly the same happened to me. I have used the latest clone-tool as posted, upgraded mk1 to the lates mk1 release, upgraded mk2 to 11d, started clone, boom. What a mess. Well had to redo all contents anyways...so I didn't mention it before. J.


Top
#11054 - 09/07/2000 01:28 Re: Clone the destroyer - WARNING [Re: jfranke]
mac
addict

Registered: 20/05/1999
Posts: 411
Loc: Cambridge, UK
Are you saying that the beta11d version of empegClone trashed your Mark 1 player? If so then this is most definitely a bug and I would like to hear about it so it can be fixed as soon as possible. The clone tool should _never_ write to the Mark 1 player. There was a bug in the beta11b version that would cause this behaviour under certain circumstances however.

--
Mike Crowe
I may not be speaking on behalf of empeg above :-)
_________________________
--
Mike Crowe

Top
#11055 - 09/07/2000 02:08 Re: Clone the destroyer - WARNING [Re: mac]
jfranke
member

Registered: 09/06/1999
Posts: 124
What I did exactly: Using emplode beta11a and the corrosponding upgrade-tool, I have upgraded MK1 to 11a and the MK2 to 11d. That worked, then I have synconized the MK1 once without changing anything in the playlists. Then I ran the latest clone tool, after that I had the mess on both players. It could well be that the MK1 was screwed up already before I ran clone, and therefor the mess off MK1 had been replicated to the MK2, I can't tell since I havent checked the playlists on MK1 before cloning. Anyways, it wasn't screwed before I did all the upgrades and cloning. J.


Top
#11056 - 09/07/2000 15:31 Re: Clone the destroyer - WARNING [Re: Big John]
mac
addict

Registered: 20/05/1999
Posts: 411
Loc: Cambridge, UK
If it came up with an error -2 (ENOENT) during the actual clone operation then either something catastrophic went wrong or your database was out of sync with the actual files on the drive. The error just means that a file it expected to be there wasn't there.

Maybe it should just log this error and carry on going.

--
Mike Crowe
I may not be speaking on behalf of empeg above :-)
_________________________
--
Mike Crowe

Top
#11057 - 09/07/2000 15:33 Re: Clone the destroyer - WARNING [Re: jfranke]
mac
addict

Registered: 20/05/1999
Posts: 411
Loc: Cambridge, UK
What I did exactly: Using emplode beta11a and the corrosponding upgrade-tool, I have upgraded MK1 to 11a and the MK2 to 11d. That worked, then I have synconized the MK1 once without changing anything in the playlists. Then I ran the latest clone tool, after that I had the mess on both players. It could well be that the MK1 was screwed up already before I ran clone, and therefor the mess off MK1 had been replicated to the MK2, I can't tell since I havent checked the playlists on MK1 before cloning. Anyways, it wasn't screwed before I did all the upgrades and cloning. J.

Ah, it appears from that list that you probably used the beta11b version of empegClone. If this was the case then you have suffered from the known bug in that version. However, your earlier post implies that you used beta11d of empegClone, if you did then there may be another bug that I am unaware of in this version.

What sort of mess did you have?

empegClone writes to the emplode.log file if logging is enabled in emplode. If you are repeating the operation then it may be worth enabling it so if anything goes wrong we can investigate more fully and hopefully correct the problem.

In any case, I hope to release a new version of empegClone early this week with much better error reporting and handling.

--
Mike Crowe
I may not be speaking on behalf of empeg above :-)
_________________________
--
Mike Crowe

Top