Unoffical empeg BBS

Quick Links: Empeg FAQ | Software | RioCar.Org | Hijack | jEmplode | emphatic
Repairs: Repairs | Addons: Eutronix | Cases

Topic Options
#361763 - 21/05/2014 16:00 How to disable Intel Speedstep (not in bios)
BartDG
carpal tunnel

Registered: 20/05/2001
Posts: 2590
Loc: Bruges, Belgium
Last year I bought an Asus N56V laptop, running Windows 7. It's main purpose was to be a work horse for my Traktor S4 DJ deck. It replaced the Apple Macbook pro (Snow Leopard) I used before that with it (because the Mac broke down and so I needed a new computer). I chose the Asus because it has a 15" Full HD screen which is very handy when DJ'ing with Traktor.

Now, with the Mac, everything worked perfectly, but with the Asus, now and the the sound stutters. This is very annoying, not to mention embarassing when DJ'ing a set. I contacted Traktor support, and they told me to use a utility called LatencyMon, which was created especially to check for latency issues on a computer which is meant to be used for real-time audio.

With the help of LatencyMon, I found out that one of the biggest culprits were the drivers for the LAN and Wifi, and the acpi.sys driver for control of the acpi battery. I disabled all these drivers in the device manager, and now everything is almost perfect. One last thing LatencyMon also noticed, is that my CPU is not running at it's full speed. It's supposed to be an i7, running at 2.3 Ghz, yet in practice it only runs at 1.8 to 1.9 Ghz. This is because of the Intel Speedstep technology, which is meant to throttle down the CPU speed when not necessary to be at full speed.

Of course, this is unnecessary (and even more: unwanted) in my case, because I need all the processing power I can get. (because otherwise latency issues might appear resulting in sound drops, pops and stutters). Now, normally you can disable the Intel Speedstep (or EIST) in the BIOS. But in this case, there's no such option available in the laptop's bios. I already flashed the bios to the latest version, but no love.

I also already tried setting the windows energy settings to "high performance" or "100%" all the time when using the laptop with a power chord (which I always do), but that doesn't seem to du much good, the CPU keeps throttling.
I searched for a small utility which could do the same, and stumbled onto SpeedSwitchXP. Unfortunately, as the name suggests, this only works for XP and I'm running Windows 7. I'm unable to find a Windows 7 alternative.

Does anybody here know of another way I could disable Intel Speedstep?

Thanks!
_________________________
Riocar 80gig S/N : 010101580 red
Riocar 80gig (010102106) - backup

Top
#361767 - 21/05/2014 17:57 Re: How to disable Intel Speedstep (not in bios) [Re: BartDG]
tfabris
carpal tunnel

Registered: 20/12/1999
Posts: 31287
Loc: Seattle, WA
Though I think that it's a good idea to answer the SpeedStep question anyway, I don't think your laptop should be having trouble playing stutter free audio even when the CPU is running at the slower 1.8ghz speed.

I think that instead, you should also be looking for bugs in the audio playback applications, the audio drivers, and the driver/application for that Traktor controller.

Another place to look for stuttering bugs is, surprisingly, the video drivers. I've found that a hitching display driver can mess up audio playback in some cases.
_________________________
Tony Fabris

Top
#361768 - 21/05/2014 19:06 Re: How to disable Intel Speedstep (not in bios) [Re: tfabris]
BartDG
carpal tunnel

Registered: 20/05/2001
Posts: 2590
Loc: Bruges, Belgium
Good idea Tony. I actually updated all the laptop's drivers already with the most recent I could find online. (with the exception of the vid card drivers, which I seem to have forgotten about blush) That is actually searching online and not using the Asus website because those don't get updated after a certain period of time. So I'm certain all the drivers on the laptop now are the most recent available.
I've already updated the chipset driver (Intel), audio driver (Realtek), LAN driver (atheros), Wifi Driver (atheros), Bluetooth driver (atheros), USB driver (Intel), touchpad driver and the cardreader driver.

As said, the only thing I didn't upgrade yet was the video card driver. This model actually uses two chipsets: and Intel 4000 (for mild desktop work, enough for my uses) and some nVidia Gforce chipset (for games - which I don't play). I'll update those as well, I don't know why I overlooked them in the first place. Thanks for the tip!

Traktor also advises to use ASIO drivers for the soundcard, but Realtek doesn't have those. I know there's always the Asio4all project, but that's still in beta and I'd hate to use beta drivers on this PC.

You'd think 1.8 Ghz would be enough, wouldn't you? I'd thought so too, but it seems this is not the case, the LatencyMon program (which is not by Traktor themselves, so it's from an unsuspected source), clearly proves that. It seems Traktor is a very demanding application. It can use up to four audio streams simultaneously, and add a bunch of effects on top of that, and this makes for a very resource-hungry program.
_________________________
Riocar 80gig S/N : 010101580 red
Riocar 80gig (010102106) - backup

Top
#361772 - 22/05/2014 00:57 Re: How to disable Intel Speedstep (not in bios) [Re: BartDG]
mlord
carpal tunnel

Registered: 29/08/2000
Posts: 14079
Loc: Canada
Still hardly a challenge for a 1.8GHz processor. Something else is wrong, or the application is simply poorly done, with insufficient buffering or something.

A 1.8GHz CPU, using only software graphics, can decode/playback 1080p 720p video along with the accompanying 6-channel Dolby audio, glitch free. Far more demanding that what you're trying.

Cheers


Edited by mlord (22/05/2014 02:31)

Top
#361775 - 22/05/2014 02:18 Re: How to disable Intel Speedstep (not in bios) [Re: BartDG]
tfabris
carpal tunnel

Registered: 20/12/1999
Posts: 31287
Loc: Seattle, WA
I've experienced problems with RealTek Audio drivers before, so it's worth poking at those to see if you can make things better there.

I've also used Asio4All as well, and was quite impressed with it. It's easy to uninstall if it doesn't solve your problem. Give it a shot. I don't think it will solve your problem but it's worth a try.

Next thing is to try to narrow down the source of your problem. Is it the player program? For instance, can you play audio or video with a different player program, and does that play without hitching? Is it the DJ controller? If you have the controller disconnected, does the hitching/sputtering stop? That sort of thing.
_________________________
Tony Fabris

Top
#361776 - 22/05/2014 02:32 Re: How to disable Intel Speedstep (not in bios) [Re: tfabris]
BartDG
carpal tunnel

Registered: 20/05/2001
Posts: 2590
Loc: Bruges, Belgium
Ok, I'll give Asio4all a try if all else fails. To be honest, I don't really know how these could help, since the Traktor comes with a high-quality external sound card built-in, and that is the one that gets used when playing. So I don't really understand how the drivers of the internal sound card come into play, but if they refer to them in their own troubleshooting guide that must be for a reason.

The problem is I cannot make changes and then simply play something and listen if the problem is still there. Sometimes the problem only occurs once for a few seconds hours into my set. So this is going to take some time to completely troubleshoot. smile
To be honest, I have good hopes things will be solved already with the changes I've made so far, because before that LatencyMon immediately turned red and gave an alarm messages the moment I started running it. With the changes I've made so far, I can play for about 15 minutes before a warning is shown. Warnings also don't automatically mean hearable glitches, only that you're in the danger zone. But even then, in 95% of the cases there was nothing wrong to hear at that time. So maybe, just maybe, the problem is already fixed. Only by doing a looooong set, I'll be able tell for sure. smile

I'd still like to get that Speedstep issue fixed though. smile
_________________________
Riocar 80gig S/N : 010101580 red
Riocar 80gig (010102106) - backup

Top
#361777 - 22/05/2014 04:31 Re: How to disable Intel Speedstep (not in bios) [Re: BartDG]
tfabris
carpal tunnel

Registered: 20/12/1999
Posts: 31287
Loc: Seattle, WA
Aha. Didn't realize the Traktor had its own sound card. Thought it was just a controller panel.

Yeah, if you're getting stutters in its audio output, and you're sure you're configured to use it as the audio output source, then its audio drivers are the first place to start looking for problems.

It seems like the kind of device which would have its own ASIO driver already (thus relieving you of the need to use ASIO4All). If so, somewhere there should be settings for its buffer sizes, which control the overall latency. Sometimes increasing the buffer size, which increases the latency, will reduce the chances of audio glitches. Which may be what you did already like you said at the top of the thread and we're going in circles now. :-)
_________________________
Tony Fabris

Top
#361778 - 22/05/2014 06:18 Re: How to disable Intel Speedstep (not in bios) [Re: mlord]
peter
carpal tunnel

Registered: 13/07/2000
Posts: 4153
Loc: Cambridge, England
Originally Posted By: mlord
Still hardly a challenge for a 1.8GHz processor. Something else is wrong, or the application is simply poorly done, with insufficient buffering or something.

This is, after all, the BBS for an audio device that ran on a 200MHz single-issue single-core 32-bit CPU, did elaborate FFT-based visualisations in real-time, and never missed a beat.

Peter

Top
#361780 - 22/05/2014 08:42 Re: How to disable Intel Speedstep (not in bios) [Re: BartDG]
Shonky
pooh-bah

Registered: 12/01/2002
Posts: 1971
Loc: Brisbane, Australia
Had the same/similar problem with a Dell XPS 15z. Their response was some bs about realtime audio being a Windows 7 problem. It was either the Wired Ethernet or Wifi driver being the main culprit. Disabling it seemed to fix the problem.

Have a skim read of:
http://forum.notebookreview.com/dell-xps...rk-traffic.html
and the first post here where some good info was collected:
http://en.community.dell.com/support-forums/laptop/f/3517/p/19434026/20091957.aspx
_________________________
Christian
#40104192 120Gb (no longer in my E36 M3, won't fit the E46 M3)

Top
#361782 - 22/05/2014 08:58 Re: How to disable Intel Speedstep (not in bios) [Re: tfabris]
BartDG
carpal tunnel

Registered: 20/05/2001
Posts: 2590
Loc: Bruges, Belgium
Originally Posted By: tfabris

It seems like the kind of device which would have its own ASIO driver already (thus relieving you of the need to use ASIO4All). If so, somewhere there should be settings for its buffer sizes, which control the overall latency. Sometimes increasing the buffer size, which increases the latency, will reduce the chances of audio glitches. Which may be what you did already like you said at the top of the thread and we're going in circles now. :-)

smile Yes. As per their instructions, I increased the USB buffer from 1 ms to 3 ms. That seemed to help a bit, but not completely solve this issue.
Things I'll try first now: 1) update the graphic card drivers as said. 2) install the Asio4all drivers and see what that gives.

Ah, btw, this is the links they've sent me with their troubleshooting guide: click. I've not tried everything on that list yet, but the things I've done so far have made a difference.
_________________________
Riocar 80gig S/N : 010101580 red
Riocar 80gig (010102106) - backup

Top
#361783 - 22/05/2014 09:02 Re: How to disable Intel Speedstep (not in bios) [Re: Shonky]
BartDG
carpal tunnel

Registered: 20/05/2001
Posts: 2590
Loc: Bruges, Belgium
Originally Posted By: Shonky
Had the same/similar problem with a Dell XPS 15z. Their response was some bs about realtime audio being a Windows 7 problem. It was either the Wired Ethernet or Wifi driver being the main culprit. Disabling it seemed to fix the problem.

Have a skim read of:
http://forum.notebookreview.com/dell-xps...rk-traffic.html
and the first post here where some good info was collected:
http://en.community.dell.com/support-forums/laptop/f/3517/p/19434026/20091957.aspx

Aha! Very interesting info, I'll read through those threads, thanks! Indeed, they said the same to me and, in their defence, disabling the Wifi driver, LAN driver and ACPI battery driver has improved the monitored results a lot. So I'm guessing the problem is fixed for me as well. To be honest, I haven't heard a stutter since, but I haven't done any three-hour sets since then either. So I'm now working at tweaking the LatencyMon results even more, in the hope this will surely fix the problem.
_________________________
Riocar 80gig S/N : 010101580 red
Riocar 80gig (010102106) - backup

Top
#361785 - 22/05/2014 12:22 Re: How to disable Intel Speedstep (not in bios) [Re: BartDG]
BartDG
carpal tunnel

Registered: 20/05/2001
Posts: 2590
Loc: Bruges, Belgium
Installing the most recent video card drivers and de Asio4all drivers didn't do very much. It's still the same result. LatencyMon still predicts problems after 12 to 15 minutes. On the bright side, I've also ran the DPC latency checker software for the first time today, and that software told me I shouldn't have any problems with real-time streaming of audio. So I have high hopes.
_________________________
Riocar 80gig S/N : 010101580 red
Riocar 80gig (010102106) - backup

Top
#361786 - 22/05/2014 13:09 Re: How to disable Intel Speedstep (not in bios) [Re: BartDG]
larry818
old hand

Registered: 01/10/2002
Posts: 995
Loc: Fullerton, Calif.
Just a thought here, I play music on my 'puter all the time while running everything I need to work, usually about a dozen programs.

I would get stuttering in the audio every time Winders decided to go off on a HDD thrash because of indexing. Indexing would also randomly tie up my 'puter for 30 seconds at the exact moment I had someone on the phone needing to know something...

Turning off indexing cured these woes. I didn't turn off the service, just disallow indexing on all the HDDs.

Top
#361788 - 22/05/2014 13:28 Re: How to disable Intel Speedstep (not in bios) [Re: larry818]
BartDG
carpal tunnel

Registered: 20/05/2001
Posts: 2590
Loc: Bruges, Belgium
Thanks for the thought Larry, but I don't think that is a problem, because I've installed an SSD into this laptop especially for this. I doubt an SSD has a problem with indexing. The DPC latency monitor also clearly shows that rather it's certain drivers that hog the system (mosty acpi.sys, iastor.sys, tcpip.sys and iusb3xhc.sys)
_________________________
Riocar 80gig S/N : 010101580 red
Riocar 80gig (010102106) - backup

Top
#361802 - 25/05/2014 07:38 Re: How to disable Intel Speedstep (not in bios) [Re: BartDG]
BartDG
carpal tunnel

Registered: 20/05/2001
Posts: 2590
Loc: Bruges, Belgium
I've looked a bit deeper into this problem and this is what I found:
- DPC latency issues are a problem with ALL Windows machines. This is due to the fact how Microsoft has built their NT kernel, where drivers cannot process data immediately in their interrupt routine, but rather has to schedule a Deferred Procedure Call (DPC), which is basically a call-back routine that will be called by the operating system as soon as possible. This by itself is a problem with real-time audio, and this is only enhanced by sloppy, lazy or just plain bad driver programming by lots of manufacturers.

- Since Intel Speedstep (or AMD's cool 'n quiet) CPU trottling has become mainstream, especially with laptops because battery-life is considered more important than raw performance. This means that, with a PC laptop, you hardly ever reach the advertised speeds of your CPU. Usually 10 - 20% less. Most manufacturers of laptops also don't include the option to disable it in the BIOS for this reason. Most people will never notice this however, since they simply don't know and only do desktop applications work or gaming with their pc, two applications where you'll never notice DPC latency issues.

There's only one manufacturer which doesn't suffer from these problems, and who does value the performance of their machines, and that's Apple. The fact that their OS is based on Unix helps a lot with this, which brings me back to this quote by Peter:

Originally Posted By: peter
(...) an audio device that ran on a 200MHz single-issue single-core 32-bit CPU, did elaborate FFT-based visualisations in real-time, and never missed a beat.

Because we all know our beloved Empeg ran Linux, and for good reason it seems now. This is probably also the reason almost all audio professionals use Mac because they know Apple does optimize their machines for real-time audio applications.

In short: I should probably invest in a Mac again, and I probably will. Traktor support hinted me in that direction as well, and they are right. Linux would have been good as well, but Traktor doesn't have a Linux version of their program.
_________________________
Riocar 80gig S/N : 010101580 red
Riocar 80gig (010102106) - backup

Top