Unoffical empeg BBS

Quick Links: Empeg FAQ | Software | RioCar.Org | Hijack | jEmplode | emphatic
Repairs: Repairs | Addons: Eutronix | Cases

Topic Options
#363773 - 02/04/2015 02:37 More SSD Issues.

Registered: 07/05/2007
Posts: 104
So, I recently installed a single 256GB Samsung mSATA card into a 44-pin 2.5" IDE adapter card with a JM20330 bridge chip in my MKIIa and have had some odd superblock mis-match issues when trying to 'rwm' and 'fsck'. I can absolutely not get 'fsck' to run on the disk. This happens when running either Developer 2.01 or Developer v3a11. Here's the gist of what's happening here when I try to mount 'rwm.'

EXT2-fs error (device ide0(3,4)): read_inode_bitmap: Cannot read inode bitmap - block_group = 1905, inode_bitmap = 62423041
attempt to access beyond end of device
03:04: rw=0, want=249823240, limit=134110620
dev 03:04 blksize=4096 blocknr=62455809 sector=499646472 size=4096 count=1
EXT2-fs error (device ide0(3,4)): read_inode_bitmap: Cannot read inode bitmap - block_group = 1906, inode_bitmap = 62455809
EXT2-fs error (device ide0(3,4)): ext2_check_inodes_bitmap: Wrong free inodes count in super block, stored = 971251, counted = 519155

It's actually quite a bit longer than that as it reports every missing block, but essentially it looks like the superblock thinks the device is half the size that it really is, and fails to "access beyond end of device." Funny that this happens, as sometimes after I've run the BigDiskv6 and installed either v2.01 or v3a11, the unit recognizes only 147GB or so, which it can actually handle without error. If I re-image, it will recognize all 256GB available, but error out on what I can only presume is the last ~100GB of the disc. What the heck?

For the record, this is what happens when I attempt to fsck.

empeg:/empeg/bin# fsck -fay /dev/hda4
Parallelizing fsck version 1.19 (13-Jul-2000)
e2fsck 1.19, 13-Jul-2000 for EXT2 FS 0.5b, 95/08/09
ext2fs_check_if_mount: No such file or directory while determining whether /dev/hda4 is mounted.
The filesystem size (according to the superblock) is 62486825 blocks
The physical size of the device is 33527655 blocks
Either the superblock or the partition table is likely to be corrupt!
Abort? yes

So given that each block is 4096k, then the physical size is 33527655x4096=137329274880, or 137GB. Filesystem size would be 62486825x4096=255946031104, or 256GB. So, there's the problem. But, why the problem? It's reporting the physical size as roughly half the actual capacity. Oh and I tried a second, identical mSATA card. Same story. I tried a second, identical adapter card. Same story. They all format to a beautiful 256GB on a normal x86 machine, through the same interfaces. So I feel safe saying there's no faulty equipment here.

Any thoughts?

#363774 - 02/04/2015 09:20 Re: More SSD Issues. [Re: FieroSTi]
carpal tunnel

Registered: 18/01/2000
Posts: 5577
Loc: London, UK
If you want to use more than 128GiB (~137GB) in an empeg, you need to install the Hijack kernel (v274 or newer). See
-- roger

#363775 - 02/04/2015 10:44 Re: More SSD Issues. [Re: FieroSTi]
carpal tunnel

Registered: 29/08/2000
Posts: 13884
Loc: Canada
Yeah, what Roger said!

The original v1/v2 kernels lack LBA48 support, so they cannot correctly address sectors on disks larger than 128GB.

#363778 - 02/04/2015 15:29 Re: More SSD Issues. [Re: FieroSTi]

Registered: 07/05/2007
Posts: 104
Sorry, I thought that was just assumed. I am running the hijack kernel. v518, to be exact.

Although Bigdisk has hijack preinstalled, I cannot find a software file with the same. Any ideas where I can find a copy of v2.01 or v3a11 with hijack pre-installed?

#363779 - 02/04/2015 15:34 Re: More SSD Issues. [Re: FieroSTi]

Registered: 27/10/2002
Posts: 568

#363783 - 02/04/2015 19:10 Re: More SSD Issues. [Re: StigOE]

Registered: 07/05/2007
Posts: 104
Originally Posted By: StigOE

Ding, ding, ding! Thanks! I knew I had found those files somewhere on Mark's site a while ago, but I couldn't again.

#363784 - 02/04/2015 21:33 Re: More SSD Issues. [Re: FieroSTi]

Registered: 07/05/2007
Posts: 104
Alright. So, I tried a Bigdisk v6 build followed by v3a11+hijack. It didn't work. That is to say, it went exactly the same. Still reports 127GB.

I'm currently attempting a bigdisk v6 build followed by v2.01+hijack. This time, I zero'd /dev/hda with 'dd' first. We'll see how this works.

#363785 - 02/04/2015 22:10 Re: More SSD Issues. [Re: FieroSTi]

Registered: 07/05/2007
Posts: 104
For what it's worth, the v2.01+hijack .upgrade file worked perfectly. The player reports 250GB, mounts 'rwm' and runs 'fsck' with zero issues. I'll try a sync tonight to make sure it really works, but I think I've got it this time.

Having said all of that, there still seems to be an LBA48 issue in the v3a11 file. Not sure if you care to fix that or not, Mark.

I sort of figured that was the issue. I just thought it was odd that I was having space cap issues when I knew I was running a Hijack kernel. Oh well. Figured it out.

#363890 - 23/04/2015 04:35 Re: More SSD Issues. [Re: FieroSTi]

Registered: 27/09/1999
Posts: 200
Loc: Berkeley, CA
I'll join the fun here. I dusted off my Mk2a and picked up a PATA<>mSATA adapter and a 500GB SSD.

Everything seems fine the v6 builder and either the v2.01 or v3a11 hijack upgrade files. I see /dev/hda4 (/drive0) as 495GB in df.

But... there's no ethernet. Switching back to the 100GB hard disk (spinning metal) restores ethernet. In chatting with Roger this morning, he suggested it might be a timing issue, since ethernet and IDE share a bus.

Anything I can try, or does this require hacking about in the kernel? Problem exists and is repeatable on both v508 (from the builders) and v518.

Full boot log:
empeg-car bootstrap v1.02 20001106 ([email protected])
If there is anyone present who wants to upgrade the flash, let them speak now,
or forever hold their seems not. Let fly the Penguins of Linux!

e000 v1.04
Copying kernel...
Calling linux kernel...
Uncompressing Linux..................................... done, booting the kernel.
Linux version 2.2.17-rmk5-np17-empeg55-hijack-v508 ([email protected]) (gcc version 2.95.3 20010315 (release)) #2 Fri Jan 9 16:06:35 EST 2009
Processor: Intel StrongARM-1100 revision 11
Checking for extra DRAM:
c1000000: wrote ffffffff, read e28cc001
NetWinder Floating Point Emulator V0.94.1 (c) 1998 Corel Computer Corp.
empeg-car player (hardware revision 9, serial number 10101243) 16MB DRAM
Command line: mem=16m
Calibrating delay loop... 207.67 BogoMIPS
Memory: 15000k/16M available (996k code, 20k reserved, 364k data, 4k init)
Dentry hash table entries: 2048 (order 2, 16k)
Buffer cache hash table entries: 16384 (order 4, 64k)
Page cache hash table entries: 4096 (order 2, 16k)
POSIX conformance testing by UNIFIX
Linux NET4.0 for Linux 2.2
Based upon Swansea University Computer Society NET3.039
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP
TCP: Hash tables configured (ehash 16384 bhash 16384)
IrDA (tm) Protocols for Linux-2.2 (Dag Brattli)
Starting kswapd v 1.5 
SA1100 serial driver version 4.27 with no serial options enabled
ttyS00 at 0xf8010000 (irq = 15) is a SA1100 UART
ttyS01 at 0xf8050000 (irq = 17) is a SA1100 UART
ttyS02 at 0xf8030000 (irq = 16) is a SA1100 UART
Signature is 67706d65 'empg'
Found custom animation at offset 0x9bb88
Tuner: loopback=0, ID=-1
show_message("Hijack v508 by Mark Lord")
empeg display initialised.
empeg dsp audio initialised
empeg dsp mixer initialised
empeg dsp initialised
empeg audio-in initialised, CS4231A revision a0
empeg remote control/panel button initialised.
empeg usb initialised, PDIUSBD12 id 0000
empeg state support initialised 0089/88c1 (save to d0005580).
empeg RDS driver initialised
empeg power-pic driver initialised (first boot)
RAM disk driver initialized:  16 RAM disks of 4096K size
empeg single channel IDE
Probing primary interface...
ide_data_test: wrote 0x0000 read 0x0000
ide_data_test: wrote 0xffff read 0x0000
ide_data_test: wrote 0xaaaa read 0x0000
ide_data_test: wrote 0x5555 read 0x0000
hda: Crucial_CT500MX200SSD3, ATA DISK drive
ide0 at 0x000-0x007,0x038 on irq 6
hda: Crucial_CT500MX200SSD3, 476940MB w/0kB Cache, CHS=60801/255/63, LBA48
empeg-flash driver initialized
smc chip id/revision 0x0100
smc_init couldn't find card
Partition check:
 hda: hda1 < hda5 hda6 > hda2 hda3 hda4
RAMDISK: ext2 filesystem found at block 0
RAMDISK: Loading 320 blocks [1 disk] into ram disk... done.
VFS: Mounted root (ext2 filesystem).
empeg-pump v0.03 (19980601)
Press Ctrl-A to enter pump...VFS: Mounted root (ext2 filesystem) readonly.
change_root: old root has d_count=1
Trying to unmount old root ... okay
Freeing unused kernel memory: 4k initempeg init 0.8
I see this is a developer image!
Mounting proc
Mounting first music partition
Tried to mount /dev/hda4 as reiserfs but got error 19
Mounting second music partition
Tried to mount /dev/hdc4 but got error 6
Error mounting partitions (possibly already mounted)
Remounting first music partition read-only
Remounting second music partition read-only
No secondary hard disk
Press 'q' now to go into development mode. You Have Zero Seconds To Com&#65533;Starting player
Timezone: EST
Hijack: intercepting config.ini

hijack: removed menu entry: "Serial Port Assignment"
kftpd: listening on port 21
khttpd: listening on port 80
  player.cpp        : 587:empeg-car 3.00-alpha11 2005/07/25.
! tags.cpp          :  61:Failed to open tags (0xc0041002).
Prolux 4 empeg car - 2.1485 Jul 25 2005
Vcb: 0x4073a000
Dead temp.sensor, status=0x00

Edited by n6mod (23/04/2015 04:36)
Mk.IIa #010101243 currently getting a 500GB SSD. More spares in the shed.

#363917 - 30/04/2015 02:51 Re: More SSD Issues. [Re: FieroSTi]

Registered: 27/09/1999
Posts: 200
Loc: Berkeley, CA
A couple of further comments here:

Hugo theorized that if the bridge chip believe that it was master, and that there was no slave, it might never release the bus. This seemed to be the case, since setting either the CS or Slave jumper allowed the ethernet to enumerate. Unfortunately, it also caused the SSD to enumerate as /dev/hdb, which would require some futzing to fix.

More interestingly, the $30 Aleratec PATA<>mSATA bridge with the nice Marvell chip displayed the bad behaviour, but the $7 bridge with the cheap JMicron bridge chip works great.

I stepped down to a 250GB SSD because it's large enough, and avoids the memory challenges that mlord mentioned around the 500GB. So far, so good. Time to load All The Music and see how it goes.
Mk.IIa #010101243 currently getting a 500GB SSD. More spares in the shed.