Unoffical empeg BBS

Quick Links: Empeg FAQ | Software | RioCar.Org | Hijack | jEmplode | emphatic
Repairs: Repairs | Addons: Eutronix | Cases

Topic Options
#305201 - 17/12/2007 18:48 empeg turns on on its own
wfaulk
carpal tunnel

Registered: 25/12/2000
Posts: 16706
Loc: Raleigh, NC US
I have had this problem for ages. I think a good number of other people do, too. I had thought that it was due to a bad leaf switch in the mains barrel connector. I soldered a jumper across the appropriate pins so that it thought it was always in DC mode. This did not solve the problem.

I got in my car this morning to a dead battery, so I figured it was time to attack the issue again, and I think I might have found the actual culprit this time.

When my ignition is off, my accessory line floats. This could cause a transient voltage between ACC and ground — enough to make the empeg think that it needs to turn on.

I'm going to try connecting a resistor between ACC and ground and see if that solves the problem. Can anyone see a problem with trying that?
_________________________
Bitt Faulk

Top
#305202 - 17/12/2007 18:57 Re: empeg turns on on its own [Re: wfaulk]
tfabris
carpal tunnel

Registered: 20/12/1999
Posts: 31223
Loc: Seattle, WA
Adding to the corresponding FAQ entry. Thanks.
_________________________
Tony Fabris

Top
#305307 - 19/12/2007 19:38 Re: empeg turns on on its own [Re: wfaulk]
wfaulk
carpal tunnel

Registered: 25/12/2000
Posts: 16706
Loc: Raleigh, NC US
Okay, I added a 4kΩ resistor between ACC and ground. The empeg still seems to operate properly. We'll see if it stops booting of its own volition now.
_________________________
Bitt Faulk

Top
#305309 - 19/12/2007 20:00 Re: empeg turns on on its own [Re: wfaulk]
tfabris
carpal tunnel

Registered: 20/12/1999
Posts: 31223
Loc: Seattle, WA
Is the resistor internal the empeg, or is it in your car's wiring harness?
_________________________
Tony Fabris

Top
#305310 - 19/12/2007 20:10 Re: empeg turns on on its own [Re: tfabris]
wfaulk
carpal tunnel

Registered: 25/12/2000
Posts: 16706
Loc: Raleigh, NC US
I put it inside the empeg — an SMT resistor soldered between the ACC and ground points on the underside of the power connector on the motherboard — but it shouldn't make any difference.

Again, though, I don't know that this is going to solve the problem.
_________________________
Bitt Faulk

Top
#305406 - 24/12/2007 02:37 Re: empeg turns on on its own [Re: wfaulk]
wfaulk
carpal tunnel

Registered: 25/12/2000
Posts: 16706
Loc: Raleigh, NC US
Didn't solve the problem. \:\(

I've tried this and shorting the power connector's switch so that it thinks that it's always on DC power.

I suppose both problems might be occurring. (I took out the power jumper when I put this in.)

I'm going to have to leave a multimeter attached to the car now to see if the ACC line is going high by itself.
_________________________
Bitt Faulk

Top
#305407 - 24/12/2007 03:47 Re: empeg turns on on its own [Re: wfaulk]
tfabris
carpal tunnel

Registered: 20/12/1999
Posts: 31223
Loc: Seattle, WA
\:\( \:\( \:\(

Let us know how the multimeter test goes. I'll update the FAQ again when we have more information. Thanks for trying to sleuth this one out.

Another interesting test might be to put the player on a 12v power source in the house (connected to the DC wiring on an extra sled, if you've got one) and see if it does the wake-up thing there. Then you could rule out car electrical system issues.
_________________________
Tony Fabris

Top
#305700 - 03/01/2008 16:29 Re: empeg turns on on its own [Re: tfabris]
edsmiata
addict

Registered: 18/08/2002
Posts: 544
Loc: New Jersey
Actually i had my MkII hooked up to my home theater over the holidays and when turned off the little blue light was merrily blinking....until the player just fired itself up and started playing....maybe some static electricity could be the culprit???
_________________________
...One man gathers what another man spills

Top
#305775 - 05/01/2008 18:17 Re: empeg turns on on its own [Re: edsmiata]
altman
carpal tunnel

Registered: 19/05/1999
Posts: 3452
Loc: Palo Alto, CA
It could be stray IR that is looking like a valid packet; this was a problem in early software releases but I believe we pretty much had it fixed by v1.03...

You could try covering the IR sensor and leaving it for a while to see if it still misbehaves maybe?

Hugo

Top
#307239 - 14/02/2008 09:32 Re: empeg turns on on its own [Re: edsmiata]
julf
veteran

Registered: 01/10/2001
Posts: 1297
Loc: Amsterdam, The Netherlands
Hmm... My empeg has started turning itself on during the night too, while it sits in a MLord dock... Doesn't seem to happen in the car.

Top
#350608 - 07/03/2012 14:08 Re: empeg turns on on its own [Re: wfaulk]
Redrum
old hand

Registered: 17/01/2003
Posts: 994

Has anyone found a resolution to the empeg’s partying by themselves?

My empeg is doing this a lot more often. My wife's empeg is in the same model car, with a similar installation and it has no issues. The empegs are both MKIIa’s

I know its not stray IR since it comes on while in the garage.

Top
#350609 - 07/03/2012 14:17 Re: empeg turns on on its own [Re: julf]
mlord
carpal tunnel

Registered: 29/08/2000
Posts: 13962
Loc: Canada
Originally Posted By: julf
Hmm... My empeg has started turning itself on during the night too, while it sits in a MLord dock... Doesn't seem to happen in the car.


Mmm.. can you connect something to capture serial port output while it sits there and does that?

Top