Unoffical empeg BBS

Quick Links: Empeg FAQ | Software | RioCar.Org | Hijack | BigDisk Builder | jEmplode | emphatic
Repairs: Repairs | Addons: Eutronix | Cases

Topic Options
#232510 - 03/09/2004 14:48 One more linux startup question.
riocanada
newbie

Registered: 08/10/2003
Posts: 78
Loc: Ontario, Canada
Thanks to all the folks on this board I've got JReceiver & tRio running beautifully on my SuSE 9.1 box.

I've been trying all of the suggestions to get both started as services (the init.d stuff) to no avail.
I've tried the suggestions on the jreceiver yahoo board, but they didn't seem to work for me.

Bascially I get the message from either the jetty.sh or jrec_jetty.sh that it can't find java. I've tried adding my java path to JAVA_LOCATIONS and setting an environment variable, neither worked. BTW my JAVA_PATH is /usr/lib/java/jre .

So I'm stumped! Any suggestions would be appreciated.
Once this is working, the windows box dies!


Cheers,

Jim.
_________________________
[3 rebadged Dell DARs, 1 Rio Receiver] [JReceiver 0.2.5 and tRio 0.1.6 on SuSE 9.3 Pro]

Top
#232511 - 03/09/2004 19:41 Re: One more linux startup question. [Re: riocanada]
riocanada
newbie

Registered: 08/10/2003
Posts: 78
Loc: Ontario, Canada
Well I've kinda answered my own question but I wouldn't mind some comments on the solution.

I've created entries in the init.d directories for both JReceiver and tRio but to get them to work I've had to copy in JAVA environment variables into the scripts as the variables do not appear to be set at this part of the boot process. The big problem with doing this is that if these variables are ever changed by the java package, these scripts will break again.

Anyway, i've put these statements in. Do I need all three of them? I'm just too lasy to try each one by themselved!

export JAVA_BINDIR=/usr/lib/java/jre/bin
export JAVA_HOME=/usr/lib/java/jre
export JAVA_ROOT=/usr/lib/java
_________________________
[3 rebadged Dell DARs, 1 Rio Receiver] [JReceiver 0.2.5 and tRio 0.1.6 on SuSE 9.3 Pro]

Top